featureCounts error???
0
0
Entering edit mode
3 months ago
Samer • 0
# get gtf
# wget #https://ftp.ensembl.org/pub/release-110/gtf/mus_musculus/Mus_musculus.GRCm39.110.gtf.gz

input.dir <- "/home/laudy/data/featurecounts/"
 setwd(input.dir)

 featureCounts -p -O -T -a /input.dir/Mus_musculus.GRCm39.110.gtf -o /input.dir/quants.txt /input.dir/PMN_CTRAligned.sortedByCoord.RD.RG.RC.out.bam

please can someone tell me what's wrong Im tried allllllll the options and he give me the same error:

Error: object 'p' not found or Error: unexpected symbol in "featureCounts thanks

featureCounts error • 438 views
ADD COMMENT
1
Entering edit mode

-T specifies the number of threads, so should have an integer after it.

It's also important to make sure you have the latest version. There were some changes in how the program handles paired-end reads, so to be sure you are doing it correctly check whether you version is current and add the --countReadPairs argument.

ADD REPLY
0
Entering edit mode

Subread is implemented both as an Unix program or as an R package. OP seems to be mixing the two versions, and I suspect they have typed a Unix command at the R prompt instead of at the Unix prompt. Typing featureCounts -p etc at the R prompt with Rsubread installed will lead to the object p not found error message.

ADD REPLY

Login before adding your answer.

Traffic: 1944 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6