Question: Error Message Received When Converting Impute File Format To Bed/Ped Files (Plink)
1
gravatar for Guan
7.8 years ago by
Guan10
Guan10 wrote:

Hi all,

I'm currently working with some GWAS data after imputation using IMPUTE, however, we are having problem to conduct SNPTEST, and has been suggested to convert the GEN and Sample files after IMPUTE to PLINK BED/PED files, then run association analysis using PLINK, to double check.

Using GTOOL, has been able to convert GEN and sample files to PED and MAP files, but when run logistic regression, ERROR: Locus rs has >2 alleles: individual 1 has genotype [ A G ] but we've already seen [ N ] and [ A ], occurred. Have tried to remove the relevant individual and snp, but still getting the same message.

The code used for the above message in PLINK was --file test_chr01 --logistic --....--out..

Trying to figure out why before to disturb my supervisor again. Any advices are appreciated. Many thanks.

Guan

gwas • 4.6k views
ADD COMMENTlink written 7.8 years ago by Guan10
6
gravatar for Joey
7.7 years ago by
Joey410
Seattle
Joey410 wrote:

I had the same problem before and one of my group members helped me out.

The error is related to that missing data: GTOOL makes the PED file with 'N' as the missing genotype, which plink doesn't recognize as missing because plink expects missing genotypes to show '-9'. Plink can understand the 'N' for missing using the following command-line parameter:

--missing-genotype N

Add this when converting GEN and sample files to PED/MAP.

ADD COMMENTlink written 7.7 years ago by Joey410
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 641 users visited in the last hour