Question: Error while running Tophat 2.0.11
0
gravatar for subodh
5.3 years ago by
subodh0
Bionivid Technology Pvt. Ltd, Bengaluru
subodh0 wrote:

Hi everyone,

I have a problem in running tophat 2.0.11 with a 50 bp paired end illumina RNA reads.

I have used following command:

./tophat2 --read-gap-length 2 -r 50 --mate-std-dev 20 -o /home/sandor/Desktop/HD/NGS_analysis/tophat-2.0.11.Linux_x86_64/tophat_out -m 0 -i 70 -I 500000 --max-insertion-length 3 --max-deletion-length 3 -p 4 --report-secondary-alignments --no-coverage-search --segment-length 25 /home/sandor/Desktop/HD/NGS_analysis/tophat-2.0.11.Linux_x86_64/hg19_indexes/hg19 A4EP_GCCAAT_L004_R1_001.fastq_filtered A4EP_GCCAAT_L004_R2_001.fastq_filtered

The output was as follows:

[2014-07-28 10:47:10] Beginning TopHat run (v2.0.11)
-----------------------------------------------
[2014-07-28 10:47:10] Checking for Bowtie
Bowtie version: 2.2.2.0
[2014-07-28 10:47:10] Checking for Samtools
Samtools version: 0.1.18.0
[2014-07-28 10:47:10] Checking for Bowtie index files (genome)..
[2014-07-28 10:47:10] Checking for reference FASTA file
[2014-07-28 10:47:10] Generating SAM header for hg19_indexes/hg19
[2014-07-28 10:48:45] Preparing reads
left reads: min. length=51, max. length=51, 25111234 kept reads (223 discarded)
right reads: min. length=51, max. length=51, 25084880 kept reads (26577 discarded)
[2014-07-28 10:58:49] Mapping left_kept_reads to genome hg19 with Bowtie2
[2014-07-28 11:29:21] Mapping left_kept_reads_seg1 to genome hg19 with Bowtie2 (1/2)
[2014-07-28 11:33:10] Mapping left_kept_reads_seg2 to genome hg19 with Bowtie2 (2/2)
[2014-07-28 11:38:02] Mapping right_kept_reads to genome hg19 with Bowtie2
[2014-07-28 12:09:08] Mapping right_kept_reads_seg1 to genome hg19 with Bowtie2 (1/2)
[2014-07-28 12:12:58] Mapping right_kept_reads_seg2 to genome hg19 with Bowtie2 (2/2)
[2014-07-28 12:18:00] Searching for junctions via segment mapping
[FAILED]

Error: segment-based junction search failed with err =-11
Loading left segment hits...

I am not getting why this error is coming.

Appreciate if anyone can help me to resolve this problem.

Thank you.

rna-seq • 2.3k views
ADD COMMENTlink modified 11 months ago by Biostar ♦♦ 20 • written 5.3 years ago by subodh0
0
gravatar for jon.brate
5.3 years ago by
jon.brate250
Norway
jon.brate250 wrote:

I think this could be a memory problem. Have you previously run tophat2 successfully? Can you try to run with only a subset of the reads?

ADD COMMENTlink written 5.3 years ago by jon.brate250

Hi jon.brate,

Thank you for your reply.

But I am running through external hard disk.

No ... I haven't run tophat2 previously... This is the first time I am running.

subset of reads ??? I haven't got that.

ADD REPLYlink written 5.3 years ago by subodh0
0
gravatar for subodh
5.3 years ago by
subodh0
Bionivid Technology Pvt. Ltd, Bengaluru
subodh0 wrote:

Hi jon.brate,

Thank you for your reply.

But I am running through external hard disk.

No ... I haven't run tophat2 previously... This is the first time I am running.

subset of reads ??? I haven't got that.

ADD COMMENTlink written 5.3 years ago by subodh0

"Memory" here probably means RAM memory, not disk space. How much RAM does your machine have?
 

ADD REPLYlink written 5.3 years ago by sndrtj180

RAM is 8 GB

ADD REPLYlink written 5.3 years ago by subodh0

Looking at this link makes it appear as that is borderline possible for the amount of reads you have. (something like 7GB for 20 million reads, about 15GB for 50 million reads).

ADD REPLYlink written 5.3 years ago by sndrtj180
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 2114 users visited in the last hour