MAUVE: No gene annotations in Genbank file alignments
1
1
Entering edit mode
9.8 years ago
tptacek3050 ▴ 70

I'm trying to align 15 genbank files generated by RAST for 15 Mycoplasma genomes that we have assembled. I am aligning the files with progressivemauve with default parameters, and visualizing with MAUVE's GUI. The alignment runs fine, but when I visualize it, I get "(no annotations loaded)" for each genome. I've tried this using a genbank file for a reference Mycoplasma genome and I get the same result.

Has anyone run into the problem before and/or does anyone have any suggestions?

software-error MAUVE RAST genbank alignment • 6.4k views
ADD COMMENT
2
Entering edit mode
9.4 years ago
izwanspp ▴ 20

I've had the same problem recently. It helps if you go through the Mauve_console, as it will mention what type of error has occurred during the run.

In my recent run for example, the console printed out a "locus line too short" error. So, in which case I simply edited the *.genbank file's information in the LOCUS row; shortening the identifier (the sample ID located to the immediate right of the "LOCUS" tag). I'm not sure exactly why, but perhaps a lengthy identifier messes with the tab delimited format, resulting in MAUVE being unable to read the file properly.

ADD COMMENT
0
Entering edit mode

I just deleted the redundant gaps in the LOCUS row, then annotation loading worked!

ADD REPLY
0
Entering edit mode

May I kindly inquire if you could provide additional insights on how you successfully resolved this issue? I'm currently in the process of aligning two chromosomes using GenBank files that contain annotations, and I'm encountering the same challenge. Your assistance would be greatly appreciated. Thank you in advance.

ADD REPLY
0
Entering edit mode

The same problem persists for me too. Running progressiveMauve on command line on bunch of gbk files. Mauve itself runs fine and I do see the output. But when I try to visualize the output file, it says no annotation loaded. Can you provide more insight on to how you fixed it will be very helpful. Thank you.

ADD REPLY

Login before adding your answer.

Traffic: 1432 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6