Question: 1000G mask with VCFtools
0
gravatar for vitti
5.6 years ago by
vitti10
United States
vitti10 wrote:

Hi all,

I'm trying to apply the 1000 Genomes masks (ftp://ftp-trace.ncbi.nlm.nih.gov/1000genomes/ftp/phase1/analysis_results/supporting/accessible_genome_masks) to the phase 3 vcfs using VCFtools with the --mask option. Strangely, my output files are always truncated down to a few hundred KB, whereas they should each span an entire chromosome. I am not sure why this is happening.

I rewrote the mask FASTA files into the format VCFtools requires, simply converting P (= pass) to 0 and everything else to 1. (I also tried using the reverse convention, as the VCFtools documentation for this option is confusing, and tried both --mask and --invert-mask for each of these). I have checked to make sure that all the information in the original FASTA files (number of characters, position of line breaks, etc.) is preserved. Does anyone know what could be causing this problem?

Thanks very much!

 

vcftools 1000 genomes mask • 1.7k views
ADD COMMENTlink modified 5.6 years ago • written 5.6 years ago by vitti10
1
gravatar for Adam
5.6 years ago by
Adam1000
United States
Adam1000 wrote:

It's quite possibly a bug. If you send us a smallish example on the vcftools-help mailing list, we'll look into it.

ADD COMMENTlink written 5.6 years ago by Adam1000

Great, thank you!

ADD REPLYlink written 5.6 years ago by vitti10

Apparently there was a bug. Has now been fixed in the SVN download version.

ADD REPLYlink written 5.6 years ago by Adam1000
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1449 users visited in the last hour