Question: tophat failed: Warning: junction database is empty!
0
gravatar for biolab
4.3 years ago by
biolab1.1k
biolab1.1k wrote:

Hi everyone

I embedded tophat command in a perl script.  When running the script, I found a tophat failure error.  I searched similar problem posts, but none of them were resolved (http://seqanswers.com/forums/showthread.php?t=41021

http://seqanswers.com/forums/showthread.php?t=27454

https://www.biostars.org/p/15366/)

Could you please provide me some advices?  I appreciate any of your answers. THANKS

error message:

[2015-03-01 18:02:45] Searching for junctions via segment mapping
Warning: junction database is empty!
[2015-03-01 18:02:45] Reporting output tracks
    [FAILED]
Error running /usr/local/tophat/bin/tophat_reports --min-anchor 8 --splice-mismatches 0 --min-

... ...

FASTQ file:

@read:C:Chr1:m:29063581:29064263:267 length=100
CACTGGTGATCAGATTGAAGTTCTTAGCAACGGAAGCTGGTGAACCATGGTATTCCATTGGAGCTTCTAAATAAGGTGAAGAAGCTGAGCTCAGATTGCT
+
IIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIII
@read1
AGGAACTTGATTAGCAAAATCTCCAAGGATTATGTGAAGCTaCTCAAGTATGGTGATTCTTTGTACCGCTGCAATTGTTCCCAATGGGAAGGAGTTCGTT
+
IIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIII
@read2
ACTCTCAGGTACCAAGTCATTGATACCCCCGGGATTTTGGATAGGCCCTTCCATGCGAAGCTCTCTGCAATCATTGACGACTTGCTGCTCTTGGTCGTAC
+
IIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIII


Reference File:

>genome
aagaaaaaggcacacacatttatattcaaaaactaagaacataggtcacacaagaaagattcatacatcacatggcaaaacaaaaaaaaacaaaaaaatataaagcctggagagcagatgccaaatttttaactatataatttggcatttatagcttaagagaaaatacataatgggtgtagataaaacagtgatagtactgtaaaaataaataaaatagtacatTTAGAGAGACTTTACAGCTAGAAAACGAGGCTCTTTAGGCATGAACTTCTGGTTTGCATAAACATCCATGTAATCTCCAAACACAAACTTTGGATACTTCTTCTCACTTCCTTCCTCTTCCGCCACCGCGGCTGGCCCTATCGCCGCCTTGTACGACGGATTGTAGAAGGAAGCTATAGACCTTCTGTTTCCTTCCTCCCTCGCCAACACCCTGTGCCACGCACTCTTGTACctgccaaccacattttggttaaaactttatactcaaaattgtatattttgtactagtgttgtcgtcgtgtcaccactgtttccggatcaagtcgagattagtgttttggttcgtaaaagatgagtgaaaaatacCTTCCGTTGCTAAGAACTTCAATCTGATCACCAGTGTTGATAACAATGGCATTAGGTAGAGGCTGAACATCGATCCACTCGCCGTCTTTCAAGACCTGAAGGCCATCATATTCATCGTCTTGGAAAAGCAAAACGACACCTCCTGCATCAGTATGAGCTCGAAGGCCATTGACTAGCTCAGGATGAGGACAAGGAGGGTAATGGCTGACTTTAGTCCCAAAGAAAGCTGTCTCTTCTCCATCTTCCATTCCTTCATTGAAAGCTTTCTTTATGTAACCTTTAGGCAAACCCAAATTCTCATCCATCACTTCCATCATCTTGCTCGCTAGCTTCCTCACTTCTTCTCTGTATTCTCCCATAGTCTCTctgtttttacgtacaaatagaaaaacacaaaggtgagatttttgaaaatgggtttgaaagattttgactagttttaaaagagaaaatgtttacTTAATGTTGGATGGCCATTCGTTTTGGTTATGGTCCAAGAGAGTGAAGACATCTTCCCAGTCCACGTTTTCTAGCTTCTCGCCAGAGTTCTTTTGAACCAATTCGTTGAGCAACTTCACGGGATTAGAAGTCTTGAATGCTTCTTCTCTCTCTGTTTTGTAGCAATCTGAGCTCAGCTTCTTCACCTTATTTAGAAGCTCCAATGGAATACCATGGTTCACCAGctacatacatacacagataagcacatgaaaacagagagacagagagagtgtgtgttctgttttttgttagttagatccgaacCTGAAAAAATCCCCACTCTTCGCAAGCTCTAGCGATTTCAGACAGTGTCTTCTCTCTTTCTTCACCATTGAGTTTGGAGAAATCGATAACAGGAATCGCCATttcagatccgcaaagagagagagagagacagatgtgtttttggcaagtcaaaaaagactctgtttagtagtaatcttctgatttagttgt

 

mapping tophat • 2.6k views
ADD COMMENTlink modified 11 months ago by Biostar ♦♦ 20 • written 4.3 years ago by biolab1.1k

Can you post the exact commands ? 

ADD REPLYlink written 4.3 years ago by geek_y9.7k

my command is : tophat2 -p 8 --b2-very-sensitive INDEX in.fq > tophat.log

ADD REPLYlink written 4.3 years ago by biolab1.1k

can u run just bowtie2 and see what happens ?

ADD REPLYlink written 4.3 years ago by geek_y9.7k
1

runing bowtie2 (bowtie2 -x INDEX -U in.fq -S out.sam) is OK.  THANKS!

ADD REPLYlink written 4.3 years ago by biolab1.1k

I am not suggesting you to run bowtie2. I just wanted to know if bowtie2 fails. If its RNA-Seq data and you are aligning to reference genome instead of transcriptome, you should use splice aware aligner like tophat2.

Which genome it is ?

ADD REPLYlink modified 4.3 years ago • written 4.3 years ago by geek_y9.7k
1

Hi Geeky, it is my test data, which contains only one sequence.  I have run true data, and tophat works now.  However, I am still confused of the error in testing.

ADD REPLYlink written 4.3 years ago by biolab1.1k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1134 users visited in the last hour