Process_Exonerate_Gff3.Pl Error
3
1
Entering edit mode
12.7 years ago
Bruno ▴ 10

I am trying to use the script processexonerategff3.pl, which converts exonerate output into gff format. Whatever I do the script returns the following error message:

Error in option spec: "gff_version|gf|v|:s"

For instance, I am using the following syntax:

perl process_exonerate_gff3.pl -t Protein infile.txt > out.gff3

the error message is produced even if I invoke the help

perl process_exonerate_gff3.pl -h

all perl modules required are installed

gff perl gene • 3.2k views
ADD COMMENT
1
Entering edit mode
12.6 years ago
Chris Penkett ▴ 490

Probably your perl or Getopt::Long module is out of date - change the relevant option description line in the process_exonerate_gff3.pl script (line 117 in the version I just downloaded) from:

'gff_version|gf|v|:s' => $gff_ver,

to something like:

'gff_version:s' => $gff_ver,

It's also possible that the options on lines 109 and 110 will cause similar issues.

Chris

ADD COMMENT
0
Entering edit mode
12.5 years ago
Neilfws 49k

You may have an old version of the script. There's a Sourceforge version (currently 3 years old) and a more recent Github version.

Note also the documentation near the top of the latter version, which states that exonerate must have been run with certain options for the script to work.

ADD COMMENT
0
Entering edit mode
12.2 years ago
Lhl ▴ 760

I used exonerate2hints.pl, which comes along with augustus.

However, i found it worked only when i produced gff files using --model protein2genome. When switching to --model est2genome, this script does work any longer.

ADD COMMENT

Login before adding your answer.

Traffic: 2237 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6