Samtools Snp Calling Problem
0
0
Entering edit mode
12.5 years ago
Liyf ▴ 300

Hi, everyone. I found a strange thing when doing snp calling using my exome sequencing data. I use BWA to map my reads to human genome hg19 and samtools whith default parameters to call snps. But when completed, I use samtools mpileup command, and accidently found that some positions, which are obvious a heterozygosis, but not in my SNP lists. I do not know why.

chr7    128141865   N   412 T$cTTTCCCCTtCTcCTCTTCCcTTTCCCCTCTtCCTTCTCcTTcCCTTTCCTTTTTTTTCCTTTCtcCCCTCCTtCTCTTcCCCTCtCTTCCTcTcCTTTcTTtTCTTccCCTCCCCCCTTcTCCCCCCttTtctTTCTCTTTcTTCTCCCTCTTCTCTCTTCcCTTTtcTTCTTTtTCTTCCTCCTTTCTTTccTCCCTTCCTTTCCTTTcctTCTCCccCTCCTCCcttCTCCtCTTTCCTtTTTtCCtcTCCTCTtTTtcCTtCTCcccCCTTCtCTTtcTCTTttCTCCCTcCCCtTCTcTTTcctCTTTTTCTccTCCCtccCTTTttcTCCccCCTCTCTttTCCctCTCCccCCtcttcttcCCCCccTCTctttCCTtTCctCCTCTtcCTcccTCTCCCc^]t^]t^]
>CDDDDDDD@F9DFDADCDCDHDDDCCDDCDDFCCCD?DDGDDECEADE>EEEECECEE>ECCEEGJFDFDFFC2FB@DDADF;EHJHE>EHHGHJHHHG8G>IHHHFGJJJ:EJJGJIJIDJJIG>EJI@J(HCIJJGIJEGCIIJJJJI@JICIIIJJH=CFGB:B2E@JIJIJFJJIGHHIJJGGIHIJ8;FHJHHHIHJHBHI9GG=FFDIJI>BDDJHHJJDFCDEJGC@BJFJJJJG<IIHBJ@BDIJJGIHBJJ?=GBDJJJ?DDJIGJIBJGBDAIGJHAAGJJIJADIJJDIJCBJJIDD<DIJHHEEIDDJFJIBDDJIJJDB7JJJDDJJ2EGJGBBJJJ?(JJHH@<HHD@@BDB?DHHHHD?HHD(BB@FDFBFFD<FFFDDA?BFDBDCC@@CCB8?@
snp snp samtools • 3.4k views
ADD COMMENT
1
Entering edit mode

It might help if you could provide the exact commands you used. Thanks.

ADD REPLY
1
Entering edit mode

The sequence formatting of your single vcf is not very helpful (as you can easily see it breaks layout completely). Further, you need to provide more evidence, about why you think, which location is the one in question and why it is 'obvious a heterozygous'. I couldn't see that at all.

ADD REPLY
1
Entering edit mode

Best to format long sequence as 'code', fixed.

ADD REPLY
1
Entering edit mode

I don't see the output of variant calling, just the mpileup output. Could you add the VCF output, also, as well as the command-line you used to produce it?

ADD REPLY
0
Entering edit mode

I just use the default parameters.

ADD REPLY
0
Entering edit mode

Michael, I just see the whole chr7 using mpileup, and using perl to identify heterozygous, this position just one of some heterozygous.I say it is heterozygous, because it has C and T both.

ADD REPLY
0
Entering edit mode

Frozenwithjoy, thank you for your kind help. I just use the default parameters on the samtools website.

ADD REPLY
0
Entering edit mode

Sean, the VCF output has no this position. Also, the SNPs I call are almost right when I check using tview command. But just like this one, tview tells me that it should be a SNP, but it is not in my result. . ,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,, . ,,,c,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,, . ...C.............................................. ,,,,,,,,,,,,,,,,,,,,,,,,,,, .. ,,c,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,, .. ,,c,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,

ADD REPLY
0
Entering edit mode

Sean, the VCF output has no this position. Also, the SNPs I call are almost right when I check using tview command. But just like this one, tview tells me that it should be a SNP, but it is not in my result.

ADD REPLY
0
Entering edit mode

I checked it, and found there are no indels around.

ADD REPLY

Login before adding your answer.

Traffic: 2182 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6