Question: spades; Failed to align paired reads
1
gravatar for dogdif
4.8 years ago by
dogdif10
dogdif10 wrote:

I ran spades with this command line

./spades.py -k 21,33,55,77,99,127 --careful --only-assembler -1 11-0910_S7_L001_R1_001.fastq.gz -2 11-0910_S7_L001_R2_001.fastq.gz -o 11_0911

and at the end

======= SPAdes pipeline finished WITH WARNINGS!

=== Error correction and assembling warnings:
 * 0:00:04.945     4M / 8M    WARN    General                 (dataset_processor.cpp     : 256)   Failed to align paired reads /Users/apple/Desktop/SPAdes-3.6.2-Darwin/bin/11-0910_S7_L001_R1_001.fastq.gz and /Users/apple/Desktop/SPAdes-3.6.2-Darwin/bin/11-0910_S7_L001_R2_001.fastq.gz

What should I do next ?

forum assembly • 4.1k views
ADD COMMENTlink modified 4.8 years ago by Michael Dondrup48k • written 4.8 years ago by dogdif10

Spades has finished with a warning, but not with an error. Please inspect the content of the output directory ./11_0911 carefully. You will find there a log file and the contigs.

ADD REPLYlink written 4.8 years ago by piet1.8k

I also have the same issue... Also I checked the output directory and there is not contigs or scaffolds in it.

I checked also my input data and is OK... the kmer used were -k 15,21,33,55,67,79,91

======= SPAdes pipeline finished abnormally and WITH WARNINGS!

=== Error correction and assembling warnings: * 0:00:01.138 16M / 5G WARN General (kmer_coverage_model.cpp : 382) Failed to determine erroneous kmer threshold. Threshold set to: 0 * 0:00:00.289 16M / 5G WARN General
(kmer_coverage_model.cpp : 217) Too many erroneous kmers, the estimates might be unreliable * 0:00:00.491 16M / 5G WARN
General (simplification.cpp : 530) The determined erroneous connection coverage threshold may be determined improperly * 0:00:00.523 16M / 5G WARN General
(pair_info_count.cpp : 195) Unable to estimate insert size for paired library #0 * 0:00:00.523 16M / 5G WARN General
(pair_info_count.cpp : 201) None of paired reads aligned properly. Please, check orientation of your read pairs. ======= Warnings saved to /Sample_A108/A108_AGTTCC_L004/spades/warnings.log

As soon as I leave default parameters or reduced the last 91 kmer the error disappeared. I don't know exactly why this happened but, it seems to works now.

Cheers.

ADD REPLYlink modified 3.9 years ago • written 3.9 years ago by Nicolas Lichilin20

Spades warns you, that the coverage with K91 is too low. Note that coverage decreases with increasing kmer size. Do not run with large kmers if you do not have enough coverage.

ADD REPLYlink written 3.9 years ago by piet1.8k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1252 users visited in the last hour