Question: Genomic assembly with spades
1
gravatar for Buffo
21 months ago by
Buffo650
Buffo650 wrote:

Hi everybody I`m using spades trying to assembly a trypanosomatid genome, i just have around 150 MB reads from nanopore sequencer, the smallest read its about 150 bp, and the longest about 84 kb, I know that i have no enough reads for genome assembly but I am trying to do it anyway, thats my command line:

spades.py --careful --nanopore --only-assembler -o out_spades -s file.fastq

It does not works, did somebody has used it before?

Thanks!

sequencing assembly genome • 1.1k views
ADD COMMENTlink modified 21 months ago by Cliff Beall450 • written 21 months ago by Buffo650
1

Maybe give the error message or describe how it fails?

ADD REPLYlink written 21 months ago by Cliff Beall450
1

== Error == file not found: /home/fcallejas/bug4/mix_b4/--only-assembler (single reads, library number: 2, library type: nanopore)

ADD REPLYlink written 21 months ago by Buffo650
1

Post your full command please. It looks like you either have typos or odd characters in your filename (so use quotes)

ADD REPLYlink written 21 months ago by fanli.gcb620
1

spades.py --nanopore --only-assembler -o bug_spades -s mix_bug4.fastq

error message == Error == file not found: /home/fcallejas/bug4/mix_b4/--only-assembler (single reads, library number: 2, library type: nanopore)

i`m doing it by tcsh script on cluster.

ADD REPLYlink written 21 months ago by Buffo650
2
gravatar for Cliff Beall
21 months ago by
Cliff Beall450
Ohio
Cliff Beall450 wrote:

Ok, actually it will only use Nanopore as part of a hybrid assembly. From the docs:

"SPAdes should not be used if only PacBio CLR, Oxford Nanopore, Sanger reads or additional contigs are available."

So it's expecting the nanopore reads filename after the --nanopore argument (which explains your error) but it's also expecting another file to do a hybrid assembly.

Do you have Illumina or other data?

ADD COMMENTlink modified 21 months ago • written 21 months ago by Cliff Beall450
1

oh! that really has sense! and no, i have no other of reads for this assembly, i wil try it with celera or canu. Thanks!

ADD REPLYlink written 21 months ago by Buffo650
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1549 users visited in the last hour