Question: Install GO.db with older version of R
0
gravatar for animesh_10kuet
3.0 years ago by
animesh_10kuet10 wrote:

I used R version (2.5.0) . I want to install GO.db but it gives error like

  1. source("http://bioconductor.org/getBioC.R")
Error in value[[3]](cond) : could not find function "numeric_version"
  
  1. source("http://bioconductor.org/biocLite.R")
Error in get(x, envir, mode, inherits) : variable ".BioC_version_associated_with_R_version" was not found
  

If i install R version(2.7.0) and install GO.db. I gives error after loading the GO.db

library(GO.db)

Error:

Loading required package: AnnotationDbi

Loading required package: Biobase

Loading required package: tools

Welcome to Bioconductor

Vignettes contain introductory material. To view, type 'openVignette()'. To cite Bioconductor, see 'citation("Biobase")' and for packages 'citation(pkgname)'.

Error: package 'DBI' required by 'AnnotationDbi' could not be found

I need to use older version of R version (2.5.0) with GO.db. How can I install GO.db with older version of R? Please Help

dbi go.db R • 1.5k views
ADD COMMENTlink modified 3.0 years ago by Jean-Karim Heriche19k • written 3.0 years ago by animesh_10kuet10
1

If possible, try to update to a more recent version of R. R 2.5.0 is almost 10 years old and 2.7.0 is over 8 years old.

ADD REPLYlink written 3.0 years ago by Jean-Karim Heriche19k

Is there any way to install old version of GO.db with newer version of R (version 3.3.0) ?

ADD REPLYlink written 3.0 years ago by animesh_10kuet10
1
gravatar for Jean-Karim Heriche
3.0 years ago by
EMBL Heidelberg, Germany
Jean-Karim Heriche19k wrote:

You need to install the DBI package which provides an interface to databases. However, the current version requires R>=2.15. You'll need to find an older version that works for R 2.7.0, probably DBI 0.2.

ADD COMMENTlink modified 3.0 years ago • written 3.0 years ago by Jean-Karim Heriche19k

How to install DBI? I am unable to install DBI (0.2)

install.packages("DBI", repos="http://cran.r-project.org/src/contrib/Archive/DBI/DBI_0.2-0.tar.gz")
  

It gives error:

Warning in install.packages("DBI", repos = "http://cran.r-project.org/src/contrib/Archive/DBI/DBI_0.2-0.tar.gz") : argument 'lib' is missing: using 'C:\Users\USER\Documents/R/win-library/2.7' Warning: unable to access index for repository http://cran.r-project.org/src/contrib/Archive/DBI/DBI_0.2-0.tar.gz/bin/windows/contrib/2.7

Warning message: package ‘DBI’ is not available

Is there any way to install old version of GO.db with newer version of R (version 3.3.0) ?

ADD REPLYlink modified 3.0 years ago • written 3.0 years ago by animesh_10kuet10

I am not familiar with Windows so I am not sure what's wrong. It could be that you don't have build tools on Windows to install packages from sources but it also seems it's trying to access http://cran.r-project.org/src/contrib/Archive/DBI/DBI_0.2-0.tar.gz/bin/windows/contrib/2.7 which doesn't exist. It could be because it's looking for files not an archive.
Try downloading the package and installing from file (you would need build tools because this is a package source, not compiled binaries):

install.packages("/path/to/DBI", repos=NULL,type="source")

or

 R CMD INSTALL DBI_0.2-0.tar.gz

To install an older version of GO.db in a recent R, use the same command.

ADD REPLYlink modified 3.0 years ago • written 3.0 years ago by Jean-Karim Heriche19k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1748 users visited in the last hour