Question: trouble with tophat
0
gravatar for ch8316f5eyu
2.7 years ago by
ch8316f5eyu10
ch8316f5eyu10 wrote:

I am new to RNA-seq, so I use Saccharomyces cerevisiae to practise this process with my owe mac. But I encoutered this problem at the first step of mapping:

[2016-07-15 17:32:05] Beginning TopHat run (v2.1.1)
-----------------------------------------------
[2016-07-15 17:32:05] Checking for Bowtie
          Bowtie version:    2.2.9.0
[2016-07-15 17:32:05] Checking for Bowtie index files (genome)..
[2016-07-15 17:32:05] Checking for reference FASTA file
[2016-07-15 17:32:05] Generating SAM header for /Users/zhangweiyu/informatics/genome/Saccharomyces_cerevisiae/UCSC/sacCer3/Sequence/Bowtie2Index/genome
[2016-07-15 17:32:05] Reading known junctions from GTF file
[2016-07-15 17:32:05] Preparing reads
     left reads: min. length=51, max. length=51, 10835367 kept reads (336 discarded)
[2016-07-15 17:35:38] Building transcriptome data files /Users/zhangweiyu/informatics/Sac/mapping/tmp/Annotation
[2016-07-15 17:35:38] Building Bowtie index from Annotation.fa
[2016-07-15 17:35:51] Mapping left_kept_reads to transcriptome Annotation with Bowtie2 
[2016-07-15 17:43:24] Resuming TopHat pipeline with unmapped reads
[2016-07-15 17:43:24] Mapping left_kept_reads.m2g_um to genome genome with Bowtie2 
[2016-07-15 17:45:07] Mapping left_kept_reads.m2g_um_seg1 to genome genome with Bowtie2 (1/2)
[2016-07-15 17:45:32] Mapping left_kept_reads.m2g_um_seg2 to genome genome with Bowtie2 (2/2)
[2016-07-15 17:46:01] Searching for junctions via segment mapping
    [FAILED]
Error: segment-based junction search failed with err =-11
Loading left segment hits...

And this is the content of segment_juncs.log:

segment_juncs v2.1.1 (d451a45)
---------------------------
[samopen] SAM header is present: 17 sequences.
Loading reference sequences...
        Loading chrI... done (230218 bases).
        Loading chrII... done (813184 bases).
        Loading chrIII... done (316620 bases).
        Loading chrIV... done (1531933 bases).
        Loading chrIX... done (439888 bases).
        Loading chrM... done (85779 bases).
        Loading chrV... done (576874 bases).
        Loading chrVI... done (270161 bases).
        Loading chrVII... done (1090940 bases).
        Loading chrVIII... done (562643 bases).
        Loading chrX... done (745751 bases).
        Loading chrXI... done (666816 bases).
        Loading chrXII... done (1078177 bases).
        Loading chrXIII... done (924431 bases).
        Loading chrXIV... done (784333 bases).
        Loading chrXV... done (1091291 bases).
        Loading chrXVI... done (948066 bases).
>> Performing segment-search:
Loading left segment hits...

My RAM is 8G, but the genome of Saccharomyces cerevisiae is so small. I really don't know what is wrong........ Thanks!

ADD COMMENTlink modified 2.7 years ago • written 2.7 years ago by ch8316f5eyu10
1

Tophat2 : Error: Segment-Based Junction Search Failed With Err =-11

How much RAM do you have? There are other options on this link.

ADD REPLYlink written 2.7 years ago by chris86250

My RAM is 8G, but the genome of Saccharomyces cerevisiae is small. Sorry, I am not good at English, what do you mean by ''There are other options on this link"? I should use other software?

ADD REPLYlink written 2.7 years ago by ch8316f5eyu10

A fix on seqanswers for this seems to be rebuilding bowtie index. Also, put your fasta file in the same directory where the bowtie index will be built. You'll save the fasta reconstruction step.

ADD REPLYlink written 2.7 years ago by chris86250

Could you provide the command and tophat+bowtie versions you;ve used please?

ADD REPLYlink written 2.7 years ago by YaGalbi1.4k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1155 users visited in the last hour