Affy old package installation in R
2
0
Entering edit mode
7.7 years ago
jk • 0

Hello Experts,

I need to install an Old package of Affy in R.

I have installed affy using following commands below: source("https://bioconductor.org/biocLite.R") biocLite("affy")

This installed affy 1.48.1 version... I need 1.36.1, is it possible to install an older version?

Regards, JK

R • 3.1k views
ADD COMMENT
1
Entering edit mode
7.7 years ago
deepue ▴ 160

Try installing the older version of Bioconductor using

install.packages("BiocInstaller", repos="http://bioconductor.org/packages/2.12/bioc")

follwed by installing the affy package.

ADD COMMENT
0
Entering edit mode

This approach seems cleaner and easier, IF it works. In an odd case of version incompatibilities, the full installation starting from the correct R version is a way to go.

ADD REPLY
0
Entering edit mode
7.7 years ago
biocyberman ▴ 860

That requires some experience with R, bioconductor and lot of patience. Still it does not guaranty you will succeed. That's said, here is somebody asking the same question: https://support.bioconductor.org/p/78304/ and the answer:

Install R-2.15 and then use the normal way (biocLite()) to install packages, the correct versions will be installed.

ADD COMMENT

Login before adding your answer.

Traffic: 1327 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6