Question: Error in SVA package
1
gravatar for niutster
4.3 years ago by
niutster100
niutster100 wrote:

Hi, I am using SVA package to remove batch effects but i get this error: Error in eigen(t(resid) %*% resid) : infinite or missing values in 'X' Does anyone know that how can i solve this problem?

R • 1.3k views
ADD COMMENTlink written 4.3 years ago by niutster100

Please include a reproducible example or at least the commands you used until you reached the error, otherwise the only think we can do is guess. Now this is a guess: do you have missing values in your data?

ADD REPLYlink written 4.3 years ago by ddiez1.9k

I am using SVA package on a methylation data file, the phenotype of interest was Mvalue(methylation value) that faced error in eigen, then to solve this error i changed my interested phenotype from Mvalue to Betavalue. In Betavalue the code was run succsessfully, this code was run: pheno=pData(gset) betavalue=getbeta(gset) mod=model.matrix(~as.factor(sample_group), data=pheno) mode0=model.matrix(~1,data=pheno) sva.results=sva(betavalue,mod,mod0) I am new to batch effects and related packages, in normalization the used package normalizes the data but in batch effect, only estimates the bach effects related to interested phenotype for example Betavalue but it is not able to correct it, could you guide me how can i remove these batch effects?

ADD REPLYlink written 4.3 years ago by niutster100

I would suggests you to read the sva vignette where how to correct for batch effect is explained in detail. In one approach that I prefer you obtain some surrogate variables that you can add to your linear model. But in the vignette there are several approaches described.

ADD REPLYlink written 4.3 years ago by ddiez1.9k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1572 users visited in the last hour
_