MLSeq package error
1
0
Entering edit mode
7.7 years ago
jonessara770 ▴ 240

Hello,

I would like to use MLSeq package but I am getting this error.

> library(MLSeq)
Error : object ‘bag.default’ is not exported by 'namespace:caret'
Error: package or namespace load failed for ‘MLSeq’

would you please help me to overcome this error?

Thanks

Sara

> sessionInfo()
R version 3.3.1 (2016-06-21)
Platform: x86_64-apple-darwin13.4.0 (64-bit)
Running under: OS X 10.12.1 (Sierra)

locale:
[1] en_CA.UTF-8/en_CA.UTF-8/en_CA.UTF-8/C/en_CA.UTF-8/en_CA.UTF-8

attached base packages:
[1] parallel  stats4    stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
 [1] edgeR_3.14.0               randomForest_4.6-12        limma_3.28.21              DESeq2_1.12.4              SummarizedExperiment_1.2.3 Biobase_2.32.0             GenomicRanges_1.24.3      
 [8] GenomeInfoDb_1.8.7         IRanges_2.6.1              S4Vectors_0.10.3           BiocGenerics_0.18.0        caret_6.0-72               ggplot2_2.1.0              lattice_0.20-34           

loaded via a namespace (and not attached):
 [1] Rcpp_0.12.7          locfit_1.5-9.1       digest_0.6.10        foreach_1.4.3        plyr_1.8.4           chron_2.3-47         acepack_1.4.1        MatrixModels_0.4-1   RSQLite_1.0.0       
[10] zlibbioc_1.18.0      minqa_1.2.4          data.table_1.9.6     annotate_1.50.1      SparseM_1.72         car_2.1-3            nloptr_1.0.4         rpart_4.1-10         Matrix_1.2-7.1      
[19] splines_3.3.1        lme4_1.1-12          BiocParallel_1.6.6   geneplotter_1.50.0   stringr_1.1.0        foreign_0.8-67       RCurl_1.95-4.8       munsell_0.4.3        mgcv_1.8-15         
[28] htmltools_0.3.5      nnet_7.3-12          gridExtra_2.2.1      htmlTable_1.7        Hmisc_4.0-0          codetools_0.2-15     XML_3.98-1.4         MASS_7.3-45          bitops_1.0-6        
[37] ModelMetrics_1.1.0   grid_3.3.1           nlme_3.1-128         xtable_1.8-2         gtable_0.2.0         DBI_0.5-1            magrittr_1.5         scales_0.4.0         stringi_1.1.2       
[46] XVector_0.12.1       reshape2_1.4.2       genefilter_1.54.2    latticeExtra_0.6-28  Formula_1.2-1        RColorBrewer_1.1-2   iterators_1.0.8      tools_3.3.1          pbkrtest_0.4-6      
[55] survival_2.40-1      AnnotationDbi_1.34.4 colorspace_1.2-7     cluster_2.0.5        knitr_1.14           quantreg_5.29
RNA-Seq • 1.7k views
ADD COMMENT
0
Entering edit mode
7.6 years ago

The error arises from importing "bag.default" function in caret. NAMESPACE is fixed in the development version 1.15.1. You can download the source files from https://github.com/Bioconductor-mirror/MLSeq. With the upcoming version 1.16.0, namespace error will be fixed in the released version.

ADD COMMENT

Login before adding your answer.

Traffic: 2678 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6