Error while downloading data using SRA toolkit
3
1
Entering edit mode
4.9 years ago
bhardwaj1991 ▴ 30

Hi,

I have been trying to download ChIP-seq data using SRA-toolkit.

prefetch -v SRR4032857

I get an error

Maximum file size download limit is 20,971,520KB

2017-01-03T09:32:45 prefetch.2.3.5 err: error unexpected while resolving tree within virtual file system module - failed to resolve accession 'SRR925811' - Obsolete software. See https://github.com/ncbi/sra-tools/wiki ( 406 )

Redirected!!!

2017-01-03T09:32:46 prefetch.2.3.5 err: name incorrect while evaluating path within network system module - Scheme is 'https' 2017-01-03T09:32:46 prefetch.2.3.5 err: path not found while resolving tree within virtual file system module - 'SRR925811' cannot be found.

I checked my hard disk space and also changed the default download folder from ./vdb-config -i. I downloaded the SRA-toolkit version 2.8.1.

What could be the issue and how can i resolve it?

sra sra-toolkit ChIP-Seq error download • 9.3k views
ADD COMMENT
4
Entering edit mode
4.9 years ago
george.ry ★ 1.1k

As per the link in the error message, SRA has moved from HTTP to HTTPS, rendering all previous versions of the SRA toolkit obsolete. You say you downloaded 2.8.1, but you still appear to be running 2.3.5, so I'd check what version is in your $PATH and where you installed the latest version.

ADD COMMENT
0
Entering edit mode

Hi george.ry

I know it shows prefetch.2.3.5 but I did download the sra-toolkit.2.8.1 from the following link: https://github.com/ncbi/sra-tools/wiki/Downloads

Also, in the directory /sratoolkit.2.8.1-ubuntu64/bin, the name of the executable file linked to

prefetch

command is prefetch.2.8.1

ADD REPLY
2
Entering edit mode
4.9 years ago
bhardwaj1991 ▴ 30

This problem has been resolved. As user george.ry pointed out there was a problem with the $PATH definition. I had used following command to install sra-toolkit

sudo apt install sra-toolkit

Apparently the executable files copied in the /usr/bin directory were older versions (I don't know why this happened) So, I did not install it this time and simply defined the path to the executables in the unzipped sra-toolkit directory.

export PATH=$PATH:$PWD/tools/sratoolkit.2.8.1-ubuntu64/bin

Now it is working without giving the earlier version error.

ADD COMMENT
0
Entering edit mode

I would highly recommend to uninstall the dated Ubuntu package: apt-get purge sra-toolkit

ADD REPLY
0
Entering edit mode
4.9 years ago
Chun-Jie Liu ▴ 280

You may check this post, I use lftp to download SRA data.

ADD COMMENT

Login before adding your answer.

Traffic: 2152 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6