Question: No best K value found
0
gravatar for kspata
4 months ago by
kspata10
kspata10 wrote:

I used command ./kmergenie <filename.fastq> running histogram estimation Setting maximum kmer length to: 251 bp computing histograms (from k=21 to k=121): ntCard wall-clock time over all k values: 0 seconds fitting model to histograms to estimate best k could not predict a best k value No best k found

Do i need to change the k value to less than 21? How can I obtain the best K value for my reads?

kmergenie assembly • 244 views
ADD COMMENTlink modified 3 months ago • written 4 months ago by kspata10
1

sorry for wrong response. well I did not install R which is a prerequisite for kmergenie. I installed it and ran the command make again.

ADD REPLYlink written 3 months ago by kspata10

If it took zero seconds, it appears that there was probably zero input, so you may want to examine the input file and make sure it was non-empty. That said, if you want to find the optimal kmer length for assembly, I suggest you read this post.

ADD REPLYlink written 4 months ago by Brian Bushnell11k

hi, can you please post the first 4 lines of your fastq file?

ADD REPLYlink written 3 months ago by Rayan Chikhi1.2k

Hi thanks for replying.. i did a minor mistake while installing the software.. now its working correctly

ADD REPLYlink written 3 months ago by kspata10
1

This is not an answer to the question. It's useless to anyone searching this problem to see that you fixed it without saying what happened. It would be courteous to tell us what was going wrong or what you found.

ADD REPLYlink written 3 months ago by karl.stamm3.1k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1215 users visited in the last hour