The installation of KissDE
2
0
Entering edit mode
4.5 years ago
wangdp123 ▴ 250

Hi there,

In order to use kissDE (http://kissplice.prabi.fr/tools/kissDE/ ), I am trying to install the DelayArray package (an dependency of DSS) (http://www.bioconductor.org/packages/release/bioc/html/DelayedArray.html) in R-3.4.0. Unfortunately, I run into some failures like this:

installing to library R-3.4.0/R-3.4.0/lib64/R/libraryâ installing source package âDelayedArrayâ ... * R * inst ** preparing package for lazy loading

Error in setMethod("arbind", "DelayedArray", .DelayedArray_arbind) :
no existing definition for function âarbindâ

Error : unable to load R code in package âDelayedArrayâ

ERROR: lazy loading failed for package âDelayedArrayâ

removing R-3.4.0/R-3.4.0/lib64/R/library/DelayedArrayâ

In addition, DelayArray package requires the R-3.4.0 version, but I am not sure about what kissDE version 1.4.0 is built on (is it R-3.4.0 or R-3.3.0?)? If it is R-3.3.0, why does it need DelayArray package?

Would you like to give me a hand about this?

Many thanks,

Regards,

Tom

SNP kissplice • 1.3k views
ADD COMMENT
1
Entering edit mode
4.4 years ago

Dear Tom, KissDE has been tested on R-3.3.3, where the version of DSS is 2.14.0 It seems that version 2.16.0 of DSS has a new dependency (DelayArray), which is causing you trouble. A way around this could be to use version 2.14.0 of DSS. Can you try this ? Best, Vincent

ADD COMMENT
0
Entering edit mode
4.4 years ago

Dear Tom, We just posted a new version of KissDE here: http://kissplice.prabi.fr/tools/kissDE/

KissDE 1.5.0 has been tested on R-3.4.0, and on our system, we did not experience any trouble with dependencies.

Best,

Vincent

ADD COMMENT

Login before adding your answer.

Traffic: 1945 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6