Question: (Closed) Problem installing Bioconductor package AnnotationDbi
0
gravatar for cristian
18 months ago by
cristian200
cristian200 wrote:

Hi,

I am having trouble installing the Bioconductor package AnnotationDbi:

biocLite('AnnotationDbi', ask = FALSE, lib = 'output/software/r/package/installation/')
BioC_mirror: https://bioconductor.org
Using Bioconductor 3.5 (BiocInstaller 1.26.1), R 3.4.0 (2017-04-21).
Installing package(s) ‘AnnotationDbi’
trying URL 'https://bioconductor.org/packages/3.5/bioc/src/contrib/AnnotationDbi_1.38.2.tar.gz'
Content type 'application/x-gzip' length 4278787 bytes (4.1 MB)
==================================================
downloaded 4.1 MB

* installing *source* package ‘AnnotationDbi’ ...
** R
** inst
** preparing package for lazy loading
Error in dyn.load(file, DLLpath = DLLpath, ...) : 
  unable to load shared object '/Users/cr517/Documents/phd/project/output/software/r/package/installation/Rcpp/libs/Rcpp.so':
  dlopen(/Users/cr517/Documents/phd/project/output/software/r/package/installation/Rcpp/libs/Rcpp.so, 6): Library not loaded: @rpath/./libgfortran.3.dylib
  Referenced from: /Users/cr517/Documents/phd/project/output/software/r/package/installation/Rcpp/libs/Rcpp.so
  Reason: image not found
ERROR: lazy loading failed for package ‘AnnotationDbi’
* removing ‘/Users/cr517/Documents/phd/project/output/software/r/package/installation/AnnotationDbi’

The downloaded source packages are in
    ‘/private/var/folders/z2/rt6qxntd3tg5bjmqlqnm0mdm0000gn/T/RtmpLXmGgy/downloaded_packages’
Updating packages 'effects', 'multcomp'
trying URL 'https://cran.rstudio.com/src/contrib/effects_4.0-0.tar.gz'
Content type 'application/x-gzip' length 1282402 bytes (1.2 MB)
==================================================
downloaded 1.2 MB

trying URL 'https://cran.rstudio.com/src/contrib/multcomp_1.4-7.tar.gz'
Content type 'application/x-gzip' length 607663 bytes (593 KB)
==================================================
downloaded 593 KB

* installing *source* package ‘effects’ ...
** package ‘effects’ successfully unpacked and MD5 sums checked
** R
** inst
** preparing package for lazy loading
Error in dyn.load(file, DLLpath = DLLpath, ...) : 
  unable to load shared object '/Users/cr517/Documents/phd/project/output/software/r/package/installation/survival/libs/survival.so':
  dlopen(/Users/cr517/Documents/phd/project/output/software/r/package/installation/survival/libs/survival.so, 6): Library not loaded: @rpath/./libgfortran.3.dylib
  Referenced from: /Users/cr517/Documents/phd/project/output/software/r/package/installation/survival/libs/survival.so
  Reason: image not found
ERROR: lazy loading failed for package ‘effects’
* removing ‘/usr/local/lib/R/3.4/site-library/effects’
* restoring previous ‘/usr/local/lib/R/3.4/site-library/effects’
* installing *source* package ‘multcomp’ ...
** package ‘multcomp’ successfully unpacked and MD5 sums checked
** R
** data
*** moving datasets to lazyload DB
** demo
** inst
** preparing package for lazy loading
Error: package or namespace load failed for ‘survival’ in dyn.load(file, DLLpath = DLLpath, ...):
 unable to load shared object '/Users/cr517/Documents/phd/project/output/software/r/package/installation/survival/libs/survival.so':
  dlopen(/Users/cr517/Documents/phd/project/output/software/r/package/installation/survival/libs/survival.so, 6): Library not loaded: @rpath/./libgfortran.3.dylib
  Referenced from: /Users/cr517/Documents/phd/project/output/software/r/package/installation/survival/libs/survival.so
  Reason: image not found
Error : package ‘survival’ could not be loaded
ERROR: lazy loading failed for package ‘multcomp’
* removing ‘/usr/local/lib/R/3.4/site-library/multcomp’
* restoring previous ‘/usr/local/lib/R/3.4/site-library/multcomp’

The downloaded source packages are in
    ‘/private/var/folders/z2/rt6qxntd3tg5bjmqlqnm0mdm0000gn/T/RtmpLXmGgy/downloaded_packages’
Warning messages:
1: In install.packages(pkgs = doing, lib = lib, ...) :
  installation of package ‘AnnotationDbi’ had non-zero exit status
2: In install.packages(update[instlib == l, "Package"], l, contriburl = contriburl,  :
  installation of package ‘effects’ had non-zero exit status
3: In install.packages(update[instlib == l, "Package"], l, contriburl = contriburl,  :
  installation of package ‘multcomp’ had non-zero exit status

It seems to start failing here:

Error in dyn.load(file, DLLpath = DLLpath, ...) : 
  unable to load shared object

My session info:

> sessionInfo()
R version 3.4.0 (2017-04-21)
Platform: x86_64-apple-darwin16.5.0 (64-bit)
Running under: macOS Sierra 10.12.6

Matrix products: default
BLAS: /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib
LAPACK: /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libLAPACK.dylib

locale:
[1] en_GB.UTF-8/en_GB.UTF-8/en_GB.UTF-8/C/en_GB.UTF-8/en_GB.UTF-8

attached base packages:
[1] stats4    parallel  stats     graphics  grDevices utils    
[7] datasets  methods   base     

other attached packages:
[1] BiocInstaller_1.26.1 IRanges_2.10.3       S4Vectors_0.14.4    
[4] Biobase_2.36.2       graph_1.54.0         BiocGenerics_0.22.0 
[7] rmarkdown_1.6        dplyr_0.7.3         

loaded via a namespace (and not attached):
 [1] doBy_4.5-15         knitr_1.17          assertthat_0.2.0   
 [4] evaluate_0.10.1     DBI_0.7             backports_1.1.0    
 [7] withr_2.0.0         pkgconfig_2.0.1     devtools_1.13.3    
[10] bindr_0.1           rlang_0.1.2         rprojroot_1.2      
[13] Matrix_1.2-11       base64enc_0.1-3     stringr_1.2.0      
[16] memoise_1.1.0       magrittr_1.5        compiler_3.4.0     
[19] RColorBrewer_1.1-2  MASS_7.3-47         stringi_1.1.5      
[22] yaml_2.1.14         grid_3.4.0          tools_3.4.0        
[25] digest_0.6.12       bindrcpp_0.2        Rcpp_0.12.12       
[28] jsonlite_1.5        R6_2.2.2            htmltools_0.3.6    
[31] glue_1.1.1          BiocParallel_1.10.1 lattice_0.20-35    
[34] tibble_1.3.4        gtable_0.2.0

Could someone help me, please?

Thanks.

Best, C.

ADD COMMENTlink modified 18 months ago • written 18 months ago by cristian200
1

You are on Mac os and it seems you don't have gfortran installed. Did you install Xcode? Anyway, you should ask this on https://support.bioconductor.org/ giving the output of sessionInfo.

ADD REPLYlink modified 18 months ago • written 18 months ago by Michael Dondrup45k

Hi,

As of gfortran:

brew search gfortran                                               

==> Searching local taps...
==> Searching taps on GitHub...
==> Searching blacklisted, migrated and deleted formulae...
GNU Fortran is now provided as part of GCC, and can be installed with:
  brew install gcc
(python2env) ➜  project brew search gcc
==> Searching local taps...
apple-gcc42     gcc ✔           gcc@4.6         gcc@4.7 ✔       gcc@4.8         gcc@4.9 ✔       gcc@5           gcc@6
==> Searching taps on GitHub...
caskroom/cask/gcc-arm-embedded
==> Searching blacklisted, migrated and deleted formulae...

And yes, I do have Xcode installed.

Thanks for the suggestion, I will ask it on bioconductor.org

Best, C.

ADD REPLYlink written 18 months ago by cristian200

Hello cristian!

Moved to support.bioconductor.org: https://support.bioconductor.org/p/100518/

For this reason we have closed your question. This allows us to keep the site focused on the topics that the community can help with.

If you disagree please tell us why in a reply below, we'll be happy to talk about it.

Cheers!

ADD REPLYlink modified 18 months ago • written 18 months ago by Michael Dondrup45k
Please log in to add an answer.
The thread is closed. No new answers may be added.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1014 users visited in the last hour