seqtk: command not found
1
0
Entering edit mode
6.7 years ago

Hi, Im using Git bash in my Windows computer, I want to install seqtk, I followed this path

git clone https://github.com/lh3/seqtk.git cd seqtk

Then when I invoke seqtk appear a message "seqtk: command not found". How can I install step by step seqtk in git bash in windows?

Thanks a lot

Adriana

RNA-Seq • 5.5k views
ADD COMMENT
1
Entering edit mode
6.7 years ago

you should compile the program: Follow the instructions on page (https://github.com/lh3/seqtk)

cd seqtk; make
ADD COMMENT
0
Entering edit mode

adriana.gallego.02 : If you don't have gcc/make/zlib installed then you would need to get those first.

$ sudo apt-get install gcc make
$ sudo apt-get install  zlib1g zlib1g-dev
ADD REPLY
0
Entering edit mode

Git bash in windows does not recognize sudo command

Thanks

ADD REPLY
1
Entering edit mode

Are you using windows 10? Then install bash on windows rather than using git bash. Simple way to do this is windows key --> bash --> Should open a new command prompt window. Will ask you if you want to install Ubuntu on windows. Follow the prompts. Create a new unix username/password. This is separate from your windows username/password.

It should take less than 10 min depending on your internet speed to download/install Ubuntu/bash.

ADD REPLY
0
Entering edit mode

" Git bash " is a msys shell included in "Git for Windows", and is a slimmed-down version of Cygwin (an old version at that), whose only purpose is to provide enough of a POSIX layer to run a bash.

ADD REPLY
0
Entering edit mode

Hi! I have a similar issue. I installed seqtk using following commands:

git clone https://github.com/lh3/seqtk.git; cd seqtk; make

then it gave me error: "seqtk: command not found"

So now I used your commands: sudo apt-get install gcc make but it tells me "apt-get: command not found"

What should I do?

ADD REPLY
0
Entering edit mode

This is the error when I follow the instructions using my Git bash in windows plattform

$ cd seqtk; make bash: make: command not found

ADD REPLY
0
Entering edit mode

See my comment above.

ADD REPLY
0
Entering edit mode

I am not sure if you can compile seqtk on windows without compilers installed (like make etc). Btw, which version of windows are you using? One of the recent versions of windows allows user to run ubuntu along with windows 10.

ADD REPLY
0
Entering edit mode

Hi, I have windows 10 and I have not been able to install seqtk in git bash. Could some body help me? It looks sudo is not recognized also.

Thanks Adriana

ADD REPLY
1
Entering edit mode

You can't use git bash as a replacement for a real bash shell. So that is not going to work for this.

Please follow the directions I gave in the post above to install Ubuntu for Win 10 and then follow the rest of the directions.

Otherwise tell us what you are trying to do with seqtk and we may be able to suggest alternative java programs that may work natively on windows.

ADD REPLY
0
Entering edit mode

Hi genomax. Is this the only way? Is it not possible to use MinGW/msys to compile it on windows?

Because I've compiled the library dependency zlib but I'm still struggling to compile seqtk. Wondering if I'm barking up the wrong tree.

Apologies if this is very naive.

ADD REPLY
0
Entering edit mode

It may be possible to use MinGW but the hassle may not be worth it.

What do you plan to use seqtk for? There may be an alternate program we can suggest that will work on Windows.

ADD REPLY
0
Entering edit mode

Thanks genomax. I needed it for pulling out fastq sequences from multiple files based on a list of sequence IDs. I actually ended up following your advice above and installing the Ubuntu subsystem. It works a charm (but wouldn't mind knowing about alternatives).

ADD REPLY
0
Entering edit mode

Also I cant install make compiller, some body can help me please?

ADD REPLY

Login before adding your answer.

Traffic: 1942 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6