Question: Unable to install ShotgunFunctionalizeR
0
gravatar for eamiller12
23 months ago by
eamiller120
eamiller120 wrote:

This is probably incredibly basic, but I'm at a loss. I am trying to install ShotgunFunctionalizeR but I keep getting warning messages. I am following the requirements and installation directions on their website.

> source("http://bioconductor.org/biocLite.R")

Bioconductor version 3.5 (BiocInstaller 1.26.1), ?biocLite for help

> biocLite()

BioC_mirror: https://bioconductor.org
Using Bioconductor 3.5 (BiocInstaller 1.26.1), R 3.4.2 (2017-09-28).

> install.packages("ShotgunFunctionalizeR", contriburl="http://shotgun.zool.gu.se")

# Seems to install with no warnings or error messages.

> library("ShotgunFunctionalizeR")

Error in library("ShotgunFunctionalizeR") : 
  there is no package called ‘ShotgunFunctionalizeR’

For some reason it's not actually being installed. I can't find it in my list of packages or call functions from it. I've also tried installation via biocLite(), but that also doesn't seem to work. Again, it seems to install, but the package doesn't appear anywhere.

> biocLite("ShotgunFunctionalizeR")

BioC_mirror: https://bioconductor.org
Using Bioconductor 3.5 (BiocInstaller 1.26.1), R 3.4.2 (2017-09-28).
Installing package(s) ‘ShotgunFunctionalizeR’
Warning message:
package ‘ShotgunFunctionalizeR’ is not available (for R version 3.4.2)

Does this have something to do with the version of R I'm using (v 3.4.2)? According to the ShotgunFunctionalizeR documentation it requires any version of R >= 1.8.0.

Since ShotgunFunctionalizeR is dependent on the Bioconductor multtest package, I also tried installing that first before installing ShotgunFunctionalizeR. I get the same results.

Any help would be much appreciated.

next-gen R software error • 869 views
ADD COMMENTlink modified 22 months ago by Biostar ♦♦ 20 • written 23 months ago by eamiller120

This is more an R question better suited to Stack Overflow.
Anyway, here are a few things to consider:
- close all R instances that might be running in parallel.
- check in the directories listed by .libPaths(). If the package is in there, delete it then reinstall it.
- check that the URL you're trying to download from is correct

The message ... not available for R version... simply means the package is not in BioConductor in this case which is why you install it from the authors website.

ADD REPLYlink modified 23 months ago • written 23 months ago by Jean-Karim Heriche20k

Thank you for your help.

I changed the URL to reflect the website (they need to update their installation instructions) and it actually installed. However, now when I type library(ShotgunFunctionalizeR) I get the following error:

Error: package ‘ShotgunFunctionalizeR’ was built before R 3.0.0: please re-install it

Does this mean I need to use a version of R before 3.0.0?

ADD REPLYlink written 23 months ago by eamiller120

I also had a similar problem once. Turning off antivirus before installing the package solved it for me.

ADD REPLYlink written 23 months ago by ashish220
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 528 users visited in the last hour