Question: Did anyone manage to successfully run HLAScan and get results?
1
gravatar for zeynep
14 months ago by
zeynep10
zeynep10 wrote:

I am trying to run HLAScan but so far I failed to get results, it always says "HLAscan cannot determine proper types".

I am getting results with every other tool I tried, only HLAScan fails to report a result!

https://bmcbioinformatics.biomedcentral.com/articles/10.1186/s12859-017-1671-3

hla-typing ngs • 1.2k views
ADD COMMENTlink modified 12 months ago by Shiqi Li0 • written 14 months ago by zeynep10

Please double check that you are doing everything as per the manual. Paste your commands here, if you wish, and tell us from where your reads originate.

ADD REPLYlink written 14 months ago by Kevin Blighe47k

Have you find the solution to deal with this question? If you have ahcieve it,can you supply your solution, Thank you

ADD REPLYlink written 12 months ago by Shiqi Li0

Which error are you receiving, 438410826?

ADD REPLYlink written 12 months ago by Kevin Blighe47k

It's always pritn "can't determine type".May be I don't uncompress my fastq file.It cause software can't read it. But thank for you reply. My name is Shiqi Li,from China

ADD REPLYlink written 12 months ago by Shiqi Li0

Hello Shiqi Li. What is the command that you used?

ADD REPLYlink written 12 months ago by Kevin Blighe47k

The follow is my command: ./hla_scan_r_v2.1.2 -t 6 -l R1.fastq.gz.paired.fq -r R2.fastq.gz.paired.fq -d data-set/db/HLA-ALL.IMGT -g HLA-A HLA-B HLA-C &>>eo & I have solved problem that "can't determine type",But when I run this command,It will Exit and in the file eo I found there print "===================================================== HLAscan v2.1 Report created

2018. 8. 15. 8:56:41

HLA gene : HLA-A

of considered types : 3182

----------- HLA-Types ----------- [Type 1] 02:03:06 EX3_232.286_100 EX2_99.2556_100 EX4_89.8623_85 EX5_246.248_100 [Type 2] 02:07:05 EX3_222.725_100 EX2_99.2667_100 EX4_11.5906_56.6667 EX5_246.248_100 " I don't know if you met this situation! Best regards.

ADD REPLYlink written 12 months ago by Shiqi Li0

It seems that the program identified that your samples are HLA-A. Is this correct?

ADD REPLYlink written 12 months ago by Kevin Blighe47k

But I don't know why I can't get relatively output? And have you met similar problem?

ADD REPLYlink modified 12 months ago • written 12 months ago by Shiqi Li0

What do you mean by 'relatively output'?

ADD REPLYlink written 12 months ago by Kevin Blighe47k

It means that I can't get corresponding result.May be I made a mistake expression.I'm so sorry

ADD REPLYlink written 12 months ago by Shiqi Li0

Do not worry, my friend. Perhaps you can contact the developers of the program: https://omictools.com/hlascan-tool

From what I can see, the program result is HLA-A, that is, the program identified that your sample sequence data contained HLA Class A.

ADD REPLYlink written 12 months ago by Kevin Blighe47k

I used new data for run this software,But it needs time is too long.In fact I have contact with author,But can't solve problem that I met

ADD REPLYlink written 12 months ago by Shiqi Li0
1

The execution time of HLAscan is too long when input fastq data is too large, because HLAscan self-align all reads in fastq with IMGT/HLA database. In this case, firstly, make bam file using alignments tools (ex: BWA-MEM), and then execute HLAscan. The execution time of HLAscan is fast (<2min for HLA-A,B,C and <30sec for others).

ADD REPLYlink written 6 months ago by SunhoLee20

I met the similar problem.When I input fastq files for running, I got the EXIT and KILLED.The log is below: HLAscan v5.0 Report created

2019. 3. 29. 19:41:7

HLA gene : HLA-E

of considered types : 17

----------- HLA-Types ----------- [Type 1] 01:03:02:01 EX3_497.134_100 EX2_280.156_100 EX4_681.949_100 EX5_306.479_100 [Type 2] 01:03:01:01 EX3_497.134_100 EX2_264.293_100 EX4_681.949_100 EX5_306.479_100

My command is "./hla_scan_r_v2.0 -l normal_wes_R1.fq -r normal_wes_R2.fq -d ./db/HLA-ALL.IMGT -v 37 -g HLA-E -t 2 > HLA-E.log ".

So I want to know what's wrong ?And if I need to input bam file ,do I run FixMateInformation,Markdupliates,RealignerTargetCreator and IndelRealigner after runing bwa-mem ? And is the reference genome IMGT/HLA database or hg19 fasta?

thx~

ADD REPLYlink modified 4 months ago • written 4 months ago by wyq011806160

Hopefully the author can help. She / He will know their program better than anybody here.

ADD REPLYlink written 12 months ago by Kevin Blighe47k

Yes,you are right.Thank for your answer my questions.Best regards

ADD REPLYlink written 12 months ago by Shiqi Li0

Did you get any answer? I have the exactly same problem. In the Mac terminal I was not able to run it and after changing to Ubuntu, I always end up with the 'HLAscan cannot determine proper types' message

ADD REPLYlink written 9 months ago by mgdias.jose10

Were you able to solve this problem? 'HLAscan cannot determine proper types' message I am having the same problem.

ADD REPLYlink written 7 months ago by ngs_star0

Did you try to contact the developer of HLAscan?

ADD REPLYlink written 7 months ago by Kevin Blighe47k

Yes, no answer yet.

ADD REPLYlink written 6 months ago by ngs_star0

I will contact them.

ADD REPLYlink written 6 months ago by Kevin Blighe47k
1

Hello. For each gene, HLAscan is executed independently. In command, just type a gene after "-g" option.

ADD REPLYlink written 6 months ago by SunhoLee20

Hi. This is very basic question but I am trying to run HLAscan and getting error.

$ ./hla_scan -l NS_L001_R1_001.fastq.gz -d A_gen.fasta
HLA-A
ERROR: wrong HLA gene

I was trying to get DB for HLA-A. The documentation shows that I need DB like this.

(1) DB HLA-ALL.IMGT : IMGT/HLA database

But I don't really understand how to input the correct database. But how do I combine all the HLA database like you did from the IMGT ftp? -d data-set/db/HLA-ALL.IMGT

Thanks in advance.

ADD REPLYlink written 11 months ago by ngs_star0

Maybe you can get DB from this url:

http://www.genomekorea.com/download/attachments/8192004/data-set.zip?version=2&modificationDate=1520919371000&api=v2

You can find this url from HLAScan website.

ADD REPLYlink modified 10 months ago • written 10 months ago by airexpend0

Inside the zipped file from the url provided by @airexpend inside of data-set/db/ folders named HLA-ALL.IMGT. just addd it in front of -d command.

$ ./hla_scan -l NS_L001_R1_001.fastq.gz -d data-set/db/HLA-ALL.IMGT
-g HLA-A
ADD REPLYlink written 9 months ago by mgdias.jose10

Thanks I was able to download the data-set/db/HLA-ALL.IMGT.

ADD REPLYlink written 7 months ago by ngs_star0

Have you solved the problem?I used fastq files to run HLAscan, and the result returned EXIT.I don't know what the problem is, could you please answer it ~ thank you

ADD REPLYlink modified 4 months ago • written 4 months ago by wyq011806160
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 660 users visited in the last hour