Question: MEME-Chip output lacks motif names
2
gravatar for Sadia
8 months ago by
Sadia50
Sadia50 wrote:

I've installed MEME locally. However, when I run meme-chip the output files do not assign known names to the motifs that were found. I know I am missing the database of motifs, but I'm not sure how to add this. Thank you for your help.

chip-seq • 337 views
ADD COMMENTlink modified 7 months ago • written 8 months ago by Sadia50
1

Thank you Gautier. I was missing the information in the command.

ADD REPLYlink written 7 months ago by Sadia50
3
gravatar for Gautier Richard
7 months ago by
MPI IE, Freiburg, Germany
Gautier Richard280 wrote:

MEME-ChIP runs several tools like MEME and DREME to find motifs, and TOMTOM to assign such motif to known Transcription Factors. TOMTOM needs some motifs databases to run. To give motifs databases to MEME-ChIP so that TFs can be assigned to your enriched motifs found by MEME or DREME, you can use the following command line:

meme-chip -oc Analysis_1 -bfile background_sequences.mbm -db DB1.meme -db DB2.meme -db DB3.meme -db DB4.meme sequences.fa

The motifs databases can be downloaded here: http://meme-suite.org/meme-software/Databases/motifs/motif_databases.12.18.tgz

ADD COMMENTlink written 7 months ago by Gautier Richard280

@Gautier Richard Hi this is quite useful thank you however I am confused about specifying the database using the link that you supplied above:

meme-chip -oc out seqs.fa

The above takes a relatively short time but the discovered motifs lack names as mentioned in the question.

However when I download your database and retry:

wget  http://meme-suite.org/meme-software/Databases/motifs/motif_databases.12.18.tgz
tar -xvf motif_databases.12.18.tgz
meme-chip -oc out -db motif_databases/MOUSE/ seqs.fa

Redoing with a database (mouse as my data are from mouse) specified has been running 4 hours and still going.... Should I expect this/ is my path to the database wrong..? The motif that I expected to show up was discovered by the original way that didn't use a database- all I need is for it to name the motif now.... but this seems to be taking a really long time...

ADD REPLYlink modified 11 weeks ago • written 11 weeks ago by chrisclarkson10080

I found out the answer to this question from : meme-chip command line usage error The following worked:

meme-chip -oc out -db motif_databases/JASPAR/JASPAR2018_CORE_vertebrates_non-redundant.meme -db motif_databases/JASPAR/JASPAR2018_CORE_vertebrates_redundant.meme seqs.fa
ADD REPLYlink written 10 weeks ago by chrisclarkson10080
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1044 users visited in the last hour