Question: how to provide background genes to do GO by david
0
gravatar for Grace_G
4 weeks ago by
Grace_G0
Grace_G0 wrote:

Hello,

Here I choose david to do GO analysis, I have the file list of Differential Expression Genes named deg.txt. Other file is background genes(human), named bg.txt.

I tried many times by david's Functional Annotation Tool, on the page left I upload my deg.txt as gene list at Step 3: List Type then did Step 4. Then I upload bg.txt next as Background at Step 3: List Type, the website seems refreshed and not save deg.txt.

So how to upload my backgroud gene list after upload deg.txt? Thanks in advance!

rna-seq next-gen gene • 150 views
ADD COMMENTlink modified 4 weeks ago • written 4 weeks ago by Grace_G0
1

Did you check if the bg.txt is in the Background panel or you cannot upload the bg.txt file?

ADD REPLYlink written 4 weeks ago by Gautier Richard240

Thanks! Yes, I checked, not shows in the background panel. I can upload after deg.txt, but after upload, it will take place of deg.txt.

ADD REPLYlink written 4 weeks ago by Grace_G0
1

Normally I think you have to upload the background first.

ADD REPLYlink written 4 weeks ago by i.sudbery3.8k

Exactly!!! Thanks! Sorry, one more question, if your interested.
Still in this process, I ignored these red word "You are either not sure..." in the picture I gave as the following, it's okay in your opinion?

ADD REPLYlink written 4 weeks ago by Grace_G0

Please paste a list of your gene IDs here.

ADD REPLYlink written 4 weeks ago by Kevin Blighe37k

All of my id likes like,

ENSG00000152583
ENSG00000184378
ENSG00000227220
ENSG00000259050
ENSG00000146070
ENSG00000183098

this I opened by sublime text3, if open directly,it looks like

ENSG00000152583ENSG00000184378ENSG00000227220ENSG00000259050ENSG00000146070...
ADD REPLYlink written 4 weeks ago by Grace_G0

After upload my deg.txt firstly, it shows

and I choose Option 1 (Recommended) to continue (since my chosen gene id as Ensembl gene id when upload)

then, it shows
actually it can give the GO result, but it without my background gene. I'm not sure here something wrong or not?

ADD REPLYlink modified 4 weeks ago • written 4 weeks ago by Grace_G0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1376 users visited in the last hour