ERROR in QIIME
0
0
Entering edit mode
15 months ago
dpc ▴ 210

Hi I want to merge some biom tables within qiime conda environment with script merge_otu_tables.py. When I use following commands, it shows following error:

COMMAND:

qiime merge_otu_tables.py -i *biom -o merge.biom
  

ERROR:

Error: QIIME 2 has no plugin/command named 'merge_otu_tables.py'.
  

Again, for the following command, following error was received:

COMMAND:

python merge_otu_tables.py -i *.biom -o merge.biom
  

ERROR:

Traceback (most recent call last):
  File "merge_otu_tables.py", line 16, in <module>
    from qiime.util import (parse_command_line_parameters, make_option,
ModuleNotFoundError: No module named 'qiime'
  

Can anyone please help me?

qiime biom merge • 640 views
ADD COMMENT
1
Entering edit mode
ADD REPLY
0
Entering edit mode

so, are you suggesting to install qiime version 1?

ADD REPLY
0
Entering edit mode

No, you can install qiime and use qiime or you can install qiime2 and use qiime2. My suggestion is to use the merge from qiime2 instead of qiime because you already installed that one. See the earlier posted link for the merge script in qiime2.

ADD REPLY
0
Entering edit mode

Thanks gb. The question is why I want to use the script? Because, I have several .biom outputs from MetaPhlAn 3.0. For each of the sample, I have one biom output. Now, I want to merge all these outputs into a single file so that I can feed into any R package. From the merge option you shared, is it possible to merge those biom output files generated from MetPhlAn 3.0?

ADD REPLY
0
Entering edit mode

Sorry, I don't know that. I only gave the comment for you to help solve the error itself. Maybe some one else will give an answer to that. Because the title of your post is now "ERROR in QIIME" you may need to create a new one with this specific question. Good luck!

ADD REPLY

Login before adding your answer.

Traffic: 2165 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6