VEP installation problem
1
0
Entering edit mode
4 months ago

Hi,everyone I tried to install one of package, but something in my environment. Could any one give me a help I download the VEP package from Ensembl, but couldn't install by following code

perl INSTALL.pl

And also output an error message shows that

Can't locate strict.pm in @INC (you may need to install the strict module) (@INC contains: /home/jimmy/anaconda3/lib/site_perl/5.26.2/x86_64-linux-thread-multi /home/jimmy/anaconda3/lib/site_perl/5.26.2 /home/jimmy/anaconda3/lib/5.26.2/x86_64-linux-thread-multi /home/jimmy/anaconda3/lib/5.26.2 .) at INSTALL.pl line 38.
BEGIN failed--compilation aborted at INSTALL.pl line 38.

What does that mean??

VEP Perl strict • 237 views
ADD COMMENT
1
Entering edit mode
4 months ago

It looks like you have a Perl installation without the strict module, which is strange. strict is used by Perl to ensure that you properly declare all your variables (ie my $variable = ...) and is commonly included in all Perl scripts and modules (including those written by Ensembl such as the VEP) as a bug-preventing measure. It surprises me that you've got a Perl installation that doesn't include strict as it's a pretty standard module. You can install strict from CPAN but honestly, if your Perl installation is missing it then I don't think it's a very good Perl installation and maybe try to install from another source.

ADD COMMENT
0
Entering edit mode

Thanks Emily So impressive suggestion.May I ask a further question? Because I download the package from Perl official (version 5.32.0) Aren't you having a Perl which is suitable for VEP?( I already try 5.26 and 5.32, but seem like not)

ADD REPLY
1
Entering edit mode

It just needs to be 5.10 or above. We've tested on 5.26 but not 5.32. See docs.

ADD REPLY
0
Entering edit mode

Ok , I got it. Thank you so much.

ADD REPLY

Login before adding your answer.

Traffic: 1270 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6