Ugene for Centos7
1
0
Entering edit mode
23 months ago

Hello!

Is there a way to install UGENE on CentOS 7? I currently don't have an opportunity to upgrade or change OS on my working server, and I consistantly get the following error: "./ugeneui: /lib64/libm.so.6: version `GLIBC_2.23' not found (required by /data/SOFT/ugene-42.0/libU2Algorithm.so)". I've tried a lot of different possible solutions, but none of them worked out. Is there a way to bypass that library version problem? May be there is some kind of container with UGENE that can be used?

Thanks in advance.

centos7 conflicts ugene software • 766 views
ADD COMMENT
0
Entering edit mode

Ugene 33 runs on RHEL7 and Scientific Linux 7, so it should also run on CentOS 7. You can get it at http://ugene.net/download-all.html

ADD REPLY
0
Entering edit mode
23 months ago

glibc being at the core of the system it can't be changed without major risk to the whole system. If you can't make the software work with an older version of glibc (or use an older version of the software that is compatible with the glibc version you have) then the solution is indeed to use a container. Check the public container registries (e.g. dockerhub, biocontainers) to see if a container is already available. Otherwise, you can build it yourself by installing the software in a container based on a recent version of Ubuntu.

ADD COMMENT

Login before adding your answer.

Traffic: 1964 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6