Need help in using dada2
0
0
Entering edit mode
21 months ago
rishav513 ▴ 30

Hello,

I am using dada2 in R for amplicon data analysis but I am facing an issue. While assigning species names to my taxa, it showed "killed" message and exited from R.

The command used for assigning species names is :

ta <- addSpecies(taxa, "silva_species_assignment_v132.fa.gz")

I think, it is showing "killed" message due to low ram on my PC, but my PC has 16GB of ram and if this task requires more ram then it would be a problem for me as currently, I can't afford it. Any suggestion to do this task in low ram space?

Any help would be appreciated.

dada2 R • 811 views
ADD COMMENT
1
Entering edit mode

You can find a couple of solutions here. As Chris Dean suggested, try to run addSpecies() in a new R session with only the taxa object and the reference silva database.

Finally, Silva v132 is a very old database. Use the Silva v138 instead

ADD REPLY
0
Entering edit mode

Thank you very much, I try to follow your suggestions.

ADD REPLY
0
Entering edit mode

By default, dada2 uses the amplicon sequence as the name of each sequence feature. This is probably inflating the amount of RAM your computer is using when the addSpecies function is called. Consider renaming the sequence features to something shorter (e.g., OTU1, OTU2 and so on..).

If that doesn't work, try cleaning up your R environment and deleting unused R objects or running the function on your university cluster (if you have access).

ADD REPLY

Login before adding your answer.

Traffic: 2865 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6