ExomeDepth installation error
1
0
Entering edit mode
16 months ago
Medha • 0

Hi all, I am trying to install ExomeDepth, my R version is 4.1.3. While using install.packages("ExomeDepth") I am facing error :

ERROR: dependencies ‘Biostrings’, ‘IRanges’, ‘Rsamtools’,‘GenomicRanges’, ‘GenomicAlignments’ are not available for package ‘ExomeDepth’

  • removing ‘/local_disk0/.ephemeral_nfs/envs/rEnv-298031e1-1448-435c-a00f-5da4c903f9f6/ExomeDepth’ Installing package into ‘/local_disk0/.ephemeral_nfs/envs/rEnv-298031e1-1448-435c-a00f-5da4c903f9f6’ (as ‘lib’ is unspecified)

    Warning: dependencies ‘Biostrings’, ‘IRanges’, ‘Rsamtools’, ‘GenomicRanges’, ‘GenomicAlignments’ are not available trying URL 'https://cloud.r-project.org/src/contrib/ExomeDepth_1.1.16.tar.gz' Content type 'application/x-gzip' length 1974890 bytes (1.9 MB)

I also tried devtools::install_github("vplagnol/ExomeDepth") which is giving same error. After this I also tried running library("ExomeDepth") as the first step provided in vignette but it shows: Error in library(ExomeDepth) : there is no package called ‘ExomeDepth’ That shows it wasnt installed successfully indeed.

I checked the version requirements too, using

                          Package        Version      Priority     Depends       
ExomeDepth "ExomeDepth"   "1.1.16"       NA        "R (>= 3.4.0)" 
ExomeDepth "ExomeDepth"    "1.1.16"      NA        "R (>= 3.4.0)"
                          Imports       
ExomeDepth  "Biostrings, IRanges, Rsamtools, GenomicRanges (>=1.23.0),\naod, VGAM (>= 0.8.4), methods, GenomicAlignments, dplyr,\nmagrittr" 
ExomeDepth "Biostrings, IRanges, Rsamtools, GenomicRanges (>= 1.23.0),\naod, VGAM (>= 0.8.4), methods, GenomicAlignments, dplyr,\nmagrittr"
                         LinkingTo Suggests Enhances License License_is_FOSS....

Now I do not understand what should be done to add these dependencies and successfully install the package. Can someone help me on this?

ExomeDepth Exome CNV • 1.6k views
ADD COMMENT
1
Entering edit mode
16 months ago
install.packages("BiocManager")
BiocManager::install(c("Biostrings", "IRanges", "Rsamtools", "GenomicRanges", "GenomicAlignments"))

Your install.packages("ExomeDepth") should then have what it needs to install. Note that you'll still need the system to have samtools installed for Rsamtools to function properly.

ADD COMMENT
0
Entering edit mode

Hi jared.andrews07 thanks for reverting back. I am new to R and just want to make sure ExomeDepth is working for the first time. For the Rsamtools we need to install samtools is what you have suggested, so can I just simply do that as in this post: How to Install SamTools, HTSLib, and BCFTools on Ubuntu 18.04 But the problem is I am using cloud workspace on databricks, how will this change?

ADD REPLY
1
Entering edit mode

No idea, I don't use databricks. I'd read the docs, find a local expert to help you out, or contact their support, likely in that order.

ADD REPLY
0
Entering edit mode

Thanks, that did work. Also in next steps, there are some arguments like bam.files, I was wondering do we require to have multiple bam files for exomedepth to run successfully (not caring for precision/accuracy)? or can we input 1 bam file?

ADD REPLY
0
Entering edit mode

Again, no idea, I haven't used this tool. You will at minimum need a reference to compare your single bam file to, so I expect you'd need at least two samples (a reference and a test). I'd read the vignette closely and just give it a shot.

ADD REPLY

Login before adding your answer.

Traffic: 1240 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6