Installing rlang version 1.1.0
1
0
Entering edit mode
14 months ago
Medha • 0

I was trying to install ExomeDepth package, after that one of its command from its document getBamCounts gives following error.

Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) : 
  namespace ‘rlang’ 1.0.5 is already loaded, but >= 1.1.0 is required
Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]): namespace ‘rlang’ 1.0.5 is already loaded, but >= 1.1.0 is required
Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]): namespace ‘rlang’ 1.0.5 is already loaded, but >= 1.1.0 is required

First thing that I do not understand is that it should have installed the version it is saying on its own. Even so, I tried installing 1.1.0 using following install.packages("rlang", version="1.1.0") . But it still installs 1.0.5. I checked if the 1.1.0 is available or not using

av <- available.packages(filters=list())
av[av[, "Package"] == "rlang", ]

               Package    Version       Priority        Depends        Imports       LinkingTo
    rlang    "rlang"        "1.1.0"          NA       "R (>= 3.5.0)"      "utils"            NA       
    rlang    "rlang"        "1.0.6"          NA       "R (>= 3.4.0)"      "utils"            NA       
               Suggests                                                                                                                                                     
    rlang    "cli (>= 3.1.0), covr, crayon, fs, glue, knitr, magrittr,\nmethods, pillar, rmarkdown, stats, testthat (>= 3.0.0), tibble,\nusethis, vctrs (>= 0.2.3), withr"
    rlang    "cli (>= 3.1.0), covr, crayon, fs, glue, knitr, magrittr,\nmethods, pillar, rmarkdown, stats, testthat (>= 3.0.0), tibble,\nusethis, vctrs (>= 0.2.3), withr"
              Enhances License                   License_is_FOSS License_restricts_use
    rlang      "winch"  "MIT + file LICENSE" NA              NA                   
    rlang      "winch"  "MIT + file LICENSE" NA              NA                   
              OS_type   Archs                           MD5sum                             NeedsCompilation File
    rlang           NA      NA          "58861e9d99517eb10f7683249efae513"      "yes"                  NA  
    rlang           NA      NA          "907bc04039194b0c7edc19e9084b14fc"      "yes"                  NA  
              Repository                               
    rlang "https://cloud.r-project.org/src/contrib"
    rlang "https://cran.microsoft.com/src/contrib"

Can someone tell me how to install rlang v1.1.0?

ExomeDepth rlang R • 8.6k views
ADD COMMENT
1
Entering edit mode
14 months ago
Lluís R. ★ 1.2k

Having a package duplicated means they are at a different .libPaths() sites. Check which version is in which directory and directly remove the version 1.0.6 or use remove.packages("rlang", lib.loc = .libPaths()[x]). Then you will be able to continue using and installing packages normally.

ADD COMMENT
0
Entering edit mode

EDIT: "It is resolved now" Thansk Lluís R. with your advice, I took out the reason for duplication, I was installing rlang 1.1.0 after installing ExomeDepth, so I reversed this by installing rlang 1.1.0 before installing ExomeDepth. Thanks.

Lluís R.

I want to install ExomeDepth, these dependencies were not getting installed on its own so I installed it before installing ExomeDepth install.packages("BiocManager")

BiocManager::install(c("Biostrings", "IRanges", "Rsamtools", "GenomicRanges", "GenomicAlignments"))

These got installed at

The downloaded source packages are in ‘/tmp/RtmpueWuwX/downloaded_packages’

Now I installed ExomeDepth: devtools::install_github("vplagnol/ExomeDepth") . Witjhin this the rlang is shown to install in this:

 installing *source* package ‘rlang’ ...

 installing to /local_disk0/.ephemeral_nfs/envs/rEnv-a66fb82e-9d00-4573-99f2-0ce76799030d/00LOCK-rlang/00new/rlang/libs

Then it showed in the end this:

  The downloaded source packages are in
  ‘/tmp/Rtmp7JiAL9/downloaded_packages’
  * checking for file ‘/tmp/Rtmp7JiAL9/remotes44847bac8a0/vplagnol-ExomeDepth-d642cbd/DESCRIPTION’ ... OK
  * preparing ‘ExomeDepth’:
  * checking DESCRIPTION meta-information ... OK
  * cleaning src
  * checking for LF line-endings in source and make files and shell scripts
  * checking for empty or unneeded directories
  * looking to see if a ‘data/datalist’ file should be added
  * building ‘ExomeDepth_1.1.16.tar.gz’

Installing package into ‘/local_disk0/.ephemeral_nfs/envs/rEnv-a66fb82e-9d00-4573-99f2-0ce76799030d’ (as ‘lib’ is unspecified)

Now I am installing this:

install.packages("rlang", version="1.1.0")

packageVersion("rlang")

This gives the path

  The downloaded source packages are in
  ‘/tmp/Rtmp7JiAL9/downloaded_packages’

Is the method you mentioned will help out here too?

ADD REPLY
0
Entering edit mode

When you edited the comment I didn't receive any notification. One thing is where a package is downloaded and where it is finally installed. install.packages doesn't have a version argument. You might be using a different package or not getting what you thought.

ADD REPLY

Login before adding your answer.

Traffic: 3302 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6