error when installing gistic2 using conda
0
0
Entering edit mode
12 weeks ago

Dear all,

How to fix the error when using conda to install the gistic2?

I already use conda to create a new directory/environment, and then conda install -hcc gistic2 as the conda website shows https://anaconda.org/HCC/gistic2

conda install -c hcc gistic2                                     
Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: / 
Found conflicts! Looking for incompatible packages.
This can take several minutes.  Press CTRL-C to abort.
failed                                                                                                                                                                                                                                                 

UnsatisfiableError: 
conda gistic2 • 460 views
ADD COMMENT
1
Entering edit mode

you did not show the actual error above, so maybe do that too

ADD REPLY
0
Entering edit mode

Thanks a lot!

Here is more detail of the error, it only shows once, and later the error does not show. I use module load to load the newest version of gcc11.3 and python3.10, but the error still shows...

UnsatisfiableError: The following specifications were found to be incompatible with each other:

Output in format: Requested package -> Available versions

Package libgcc-ng conflicts for:
gistic2 -> zlib[version='>=1.2.11,<1.3.0a0'] -> libgcc-ng[version='>=11.2.0|>=7.5.0|>=7.3.0|>=7.2.0']
python=3.7 -> libgcc-ng[version='>=11.2.0|>=7.5.0|>=7.3.0|>=7.2.0']The following specifications were found to be incompatible with your system:

  - feature:/linux-64::__glibc==2.28=0
  - python=3.7 -> libgcc-ng[version='>=11.2.0'] -> __glibc[version='>=2.17']

Your installed version is: 2.28
ADD REPLY
1
Entering edit mode

create a new empty environment and see if you can install into that

module loading should not be necessary and may even be counterproductive here, conda cannot reuse local libraries

 conda create -n test -c hcc gistic2

it might still not work, it looks like some libraries are not compatible anymore

also try the binary package perhaps

https://broadinstitute.github.io/gistic2/

ADD REPLY
0
Entering edit mode

Sure, creating a new environment still does not work, guess the compatibility still needs to be solved, which is most likely not possible by the normal user without root. And the binary package might be the best solution.

Thank you very much for your professional guidance! Appreciate it a lot!

ADD REPLY

Login before adding your answer.

Traffic: 2320 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6