Attempting to Use circlator running into issues with CANU
0
0
Entering edit mode
21 days ago

Hi!

I am attempting to circularize my assembly and have been running into the following issue, I also posted the slurm script I am trying to run it with.

I am using Canu 1.7.1 if that is of any help as the latest version would be recognized by Circlator.

canu -useGrid=false gnuplotTested=true -assemble genomeSize=0.1m -d /storage/work/dfl5440/Kim_Ritchie_Bacteria/circulization/BC1_INITIAL/03.assemble -p canu -pacbio-corrected /storage/work/dfl5440/Kim_Ritchie_Bacteria/circulization/BC1_INITIAL/02.bam2reads.fasta

The output was:

-- WARNING:
-- WARNING:  Option '-pacbio-corrected' is deprecated.
-- WARNING:  Use options '-corrected -pacbio <files>' in the future.
-- WARNING:

usage:   canu [-version] [-citation] \
              [-haplotype | -correct | -trim | -assemble | -trim-assemble] \
              [-s <assembly-specifications-file>] \
               -p <assembly-prefix> \
               -d <assembly-directory> \
               genomeSize=<number>[g|m|k] \
              [other-options] \
              [-haplotype{NAME} illumina.fastq.gz] \
              [-corrected] \
              [-trimmed] \
              [-pacbio |
               -nanopore |
               -pacbio-hifi] file1 file2 ...

example: canu -d run1 -p godzilla genomeSize=1g -nanopore-raw reads/*.fasta.gz


  To restrict canu to only a specific stage, use:
    -haplotype     - generate haplotype-specific reads
    -correct       - generate corrected reads
    -trim          - generate trimmed reads
    -assemble      - generate an assembly
#!/bin/bash
#SBATCH --job-name=circle_01
#SBATCH --nodes=1
#SBATCH --ntasks=12
#SBATCH --time=20:00:00
#SBATCH --mem=60G

#Variables
export ASSEMBLY=path/to/assembly.fasta
export READS=path/to/barcode01_trimmed100.fastq
export OUTPUT=path/to/directory/BC1_INITIAL

#Command
circlator all --assembler canu --threads $SLURM_NTASKS $ASSEMBLY $READS $OUTPUT
canu circlator • 273 views
ADD COMMENT
0
Entering edit mode

Looks like canu does not like the options that are being fed to it by circlator. Are you able to use a newer version of canu (latest seems to be v.2.2) ? circlator manual does not specify what version of canu it works with. Alternate option is to use SPAdes where compatible versions are defined by circlator.

ADD REPLY
0
Entering edit mode

I attempted to run it with canu v2.2 and 2.1 but circlator could not find the version number when I installed those versions. I would prefer to use canu but at this point I have tried a fair bit of solutions only to continue to run into errors.

ADD REPLY

Login before adding your answer.

Traffic: 1297 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6