Question: Mapsplice Reads Format Error
0
gravatar for Gabrielw
8.3 years ago by
Gabrielw60
Rio de Janeiro
Gabrielw60 wrote:

I'm trying to use mapsplice,I used an SRA database file ERR015688.fastq , against hg19 reference genome and bowtie index into the same directory

my command:

$ python bin/mapsplice_segments.py -Q fq -u /storage/gwajnberg/ERR015688/ERR015688.fastq -c /storage/data/gabriel/ucsc/hg19/ -B /storage/data/gabriel/ucsc/hg19/hg19 -o /storage/gwajnberg/mapsplice_out/

what happened:

[Wed Aug 31 16:07:31 2011] Preparing output location /storage/gwajnberg/mapsplice_out//


[Wed Aug 31 16:07:32 2011] Beginning Mapsplice run (v1.15.2)

-----------------------------------------------

bin directory: [/storage/app/MapSplice_1.15.2/bin/] 

[Wed Aug 31 16:07:32 2011] Checking for chromosomes files or directory

base name of chromosome file not consistent with chromosome name

base chromosome file name:hg19

chromosome name:chr10

[Wed Aug 31 16:07:32 2011] format chromosome files

[Wed Aug 31 16:09:43 2011] Checking for Bowtie index files

[Wed Aug 31 16:09:43 2011] Indexing chromosome sequences

[Wed Aug 31 19:09:30 2011] check reads format

read name contain blank space or tab

the 1th read in /storage/gwajnberg/ERR015688/ERR015688.fastq

@ERR015688.1 F2JR09301DGOLY length=270

    [FAILED]

Error: check reads format failed

Does anyone know what happened??? thanks

read fastq error • 3.2k views
ADD COMMENTlink modified 8.3 years ago by Istvan Albert ♦♦ 82k • written 8.3 years ago by Gabrielw60
1

I 've discovered what happened example: @ERR015688.1 F2JR09301DGOLY length=270 It doesn t accept blank spaces...so I had to remove them...then it worked... now the program stopped at another point!

ADD REPLYlink written 8.3 years ago by Gabrielw60

can you add the the result of "head -n 20 /storage/gwajnberg/ERR015688/ERR015688.fastq" ?

ADD REPLYlink written 8.3 years ago by Pierre Lindenbaum124k

I had the same error... you can use ´sed 's/ /_/g' ERR015688.fastq´

ADD REPLYlink written 8.2 years ago by Geparada1.4k

I had the same error... and I use: sed 's/ /_/g' reads.fastq and then works nice.

ADD REPLYlink written 8.2 years ago by Geparada1.4k
2
gravatar for Istvan Albert
8.3 years ago by
Istvan Albert ♦♦ 82k
University Park, USA
Istvan Albert ♦♦ 82k wrote:

from the error message it sounds like the sequence for each chromosome needs to be in a separate file that is named after the chromosome.

See the manual: http://www.netlab.uky.edu/p/bioinfo/MapSpliceManual

ADD COMMENTlink written 8.3 years ago by Istvan Albert ♦♦ 82k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1149 users visited in the last hour