Question: trouble with installing DiffBind R package
0
gravatar for eem0306
3.0 years ago by
eem03060
Korea, Republic Of
eem03060 wrote:

I try to install "R package; DiffBind"

I think other depends package was installed well.. 

but I got a problem like this;

(I tried to do this in a various versions of R, such as R 3.1.1 or R 2.15.0)

 

** R
** inst
** preparing package for lazy loading
** help
*** installing help indices
** building package indices
** installing vignettes
   ‘Rsamtools-Overview.Rnw’
   ‘Rsamtools-UsingCLibraries.Rnw’
** testing if installed package can be loaded
Error in dyn.load(file, DLLpath = DLLpath, ...) :
  unable to load shared object '/data/eem0306/R-2.15.0/library/Rsamtools/libs/Rsamtools.so':
  /data/eem0306/R-2.15.0/library/Rsamtools/libs/Rsamtools.so: undefined symbol: gzopen64
Error: loading failed
Execution halted
ERROR: loading failed
* removing ‘/data/eem0306/R-2.15.0/library/Rsamtools’
ERROR: dependency ‘RSQLite’ is not available for package ‘AnnotationDbi’
* removing ‘/data/eem0306/R-2.15.0/library/AnnotationDbi’
ERROR: dependency ‘AnnotationDbi’ is not available for package ‘annotate’
* removing ‘/data/eem0306/R-2.15.0/library/annotate’
ERROR: dependencies ‘AnnotationDbi’, ‘annotate’ are not available for package ‘genefilter’
* removing ‘/data/eem0306/R-2.15.0/library/genefilter’
ERROR: dependencies ‘annotate’, ‘AnnotationDbi’ are not available for package ‘geneplotter’
* removing ‘/data/eem0306/R-2.15.0/library/geneplotter’
ERROR: dependencies ‘genefilter’, ‘geneplotter’ are not available for package ‘DESeq’
* removing ‘/data/eem0306/R-2.15.0/library/DESeq’
ERROR: dependencies ‘gplots’, ‘DESeq’ are not available for package ‘DiffBind’
* removing ‘/data/eem0306/R-2.15.0/library/DiffBind’

The downloaded source packages are in
        ‘/tmp/RtmpzoA8Si/downloaded_packages’
Updating HTML index of packages in '.Library'
Making packages.html  ... done
Warning messages:
1: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
  installation of package ‘RSQLite’ had non-zero exit status
2: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
  installation of package ‘Rsamtools’ had non-zero exit status
3: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
  installation of package ‘AnnotationDbi’ had non-zero exit status
4: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
  installation of package ‘annotate’ had non-zero exit status
5: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
  installation of package ‘genefilter’ had non-zero exit status
6: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
  installation of package ‘geneplotter’ had non-zero exit status
7: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
  installation of package ‘DESeq’ had non-zero exit status
8: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
  installation of package ‘DiffBind’ had non-zero exit status
>

chip-seq R software error • 1.9k views
ADD COMMENTlink written 3.0 years ago by eem03060

Do you not have zlib installed?

ADD REPLYlink written 3.0 years ago by Devon Ryan73k

you mean 

zlibbioc ??

ADD REPLYlink written 3.0 years ago by eem03060

No, the base zlib on your system, completely independent from R/Bioconductor. The root of the problem you reported is this line:

/data/eem0306/R-2.15.0/library/Rsamtools/libs/Rsamtools.so: undefined symbol: gzopen64

The function gzopen64() is defined in zlib, so either (A) you don't have that installed (highly unlikely), (B) somehow R isn't finding it, or (C) somehow you have a version of zlib without gzopen64(). In any case, have a look through this thread on the bioconductor site for help.

ADD REPLYlink written 3.0 years ago by Devon Ryan73k

I tried to install all of zlib...

and it showed a list of installed zlib like this

 

 

Setting up Install Process
Package zlib-devel-1.2.3-29.el6.x86_64 already installed and latest version
Package jzlib-javadoc-1.0.7-7.5.el6.x86_64 already installed and latest version
Package zlib-1.2.3-29.el6.x86_64 already installed and latest version
Package jzlib-demo-1.0.7-7.5.el6.x86_64 already installed and latest version
Package zlib-static-1.2.3-29.el6.x86_64 already installed and latest version
Package jzlib-1.0.7-7.5.el6.x86_64 already installed and latest version
Nothing to do

Am I wrong? T.T..

ADD REPLYlink written 3.0 years ago by eem03060
1

Right, so follow the instructions in the link I posted previously to try and determine the root of the problem.

ADD REPLYlink written 3.0 years ago by Devon Ryan73k

OK!! I Will try!! 

Thx So much!

ADD REPLYlink written 3.0 years ago by eem03060
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 957 users visited in the last hour