Question: Black color reads in IGV: bwa-meth
1
gravatar for mehran.karimzade
4.3 years ago by
Canada
mehran.karimzade160 wrote:

Using bwa-meth for whole genome bisulfite sequencing, I found that reads are shown in black.

Same file analyzed by Bismark, has grey colour reads az expected.

 

Example of reads:

BWA-meth file Ex_1:
HWI-ST762:353:C5PD6ACXX:7:2202:10147:48446      163     chr1    10005   12      99M     =       10092   145     CCTAACCCTAACCCTAACCCTAACCCTAACCCTAACCCTAACCCTAACCCTAACCCTAACCCTAACCCTAACCCTAACCCTAACCCTAACCCTAACCCT     BBBFFFFFFFFFFF<BFFFIBFFFBFFFIFIFBFFFIFFIIFFBFFIIIBFFFFFI'7<BFF7BFFFFBBBBBB0<BBBB0777BBBB7BBBBBBBBBB  YC:Z:GA MD:Z:99 YD:Z:r  PG:Z:MarkDuplicates     RG:Z:HI.2280.007.Index_3.SE_pair_val_   NM:i:0  AS:i:99 XS:i:99

Bismark-bowtie2 Ex_2:
HWI-ST762:353:C5PD6ACXX:4:2102:15861:95520/1    163     chr1    10005   42      99M     =       10059   105     CCTAACCCTAACCCTAACCCTAACCCTAACCCTAACCCTAACCCTAACCCTAACCCTAACCCTAACCCTAACCCTAACCCTAACCCTAACCCTAACCCT     BBBFFFFFFFBFBFFFFIIFBFFFIIIF<FBFFFIFFFBFBBFFFFFFFIIBF<FB<<BF0B'77BBF<77<BB<BBBBB<B<7<<77B7<B7BBB7B<  MD:Z:99 PG:Z:MarkDuplicates.2   XG:Z:GA NM:i:0  XM:Z:...................................................................................................    XR:Z:GA

 

The only difference I noticed is the fact that pair information is not available in bwa-meth output. However as you see in the screenshot, IGV is able to find reads. I would appreciate any input on what might be the reason.

 

Many thanks

Mehran

bwa-meth igv alignment • 2.1k views
ADD COMMENTlink written 4.3 years ago by mehran.karimzade160
2

The pairing information is there in both, but the methylation call string isn't there for bwa-meth (it doesn't produce it). Perhaps that's the reason IGV is treating the alignments differently.

ADD REPLYlink written 4.3 years ago by Devon Ryan91k
2

You are right. I got this from Jim Robinson IGV mailing list:

"This is caused by the "YC" tag, which igv interprets as an explicit color setting.  This is a common use of this tag, not in the spec as Y is user-defined but a common long-standing convention that IGV supports.  In this case it tries to convert "GA" to a color and fails so black is used."

Thanks

ADD REPLYlink written 4.3 years ago by mehran.karimzade160

good to know

ADD REPLYlink written 4.2 years ago by brentp23k

Is the YC tag used by other tools downstream? Can it be changed to another tag with no consequences?

ADD REPLYlink written 3.6 years ago by 141341254653464453.5k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 914 users visited in the last hour