Question: dependency plyr in R 2.15.1
0
gravatar for yueli7
4.4 years ago by
yueli790
China
yueli790 wrote:

Hi,

I try to install qvalue.

It seems dependency ‘plyr’ is not available. My R version is R 2.15.1

 

> source("http://bioconductor.org/biocLite.R")
A new version of Bioconductor is available after installing the most
  recent version of R; see http://bioconductor.org/install
Bioconductor version 2.11 (BiocInstaller 1.8.3), ?biocLite for help
> biocLite("qvalue")
BioC_mirror: http://bioconductor.org
Using Bioconductor version 2.11 (BiocInstaller 1.8.3), R version 2.15.
Installing package(s) 'qvalue'
试开URL’http://bioconductor.org/packages/2.11/bioc/src/contrib/qvalue_1.32.0.tar.gz'
Content type 'application/x-gzip' length 512386 bytes (500 Kb)
打开了URL
==================================================
downloaded 500 Kb

* installing *source* package ‘qvalue’ ...
** R
** data
** inst
** preparing package for lazy loading
** help
*** installing help indices
** building package indices
** installing vignettes
   ‘qvalue.Rnw’
** testing if installed package can be loaded

* DONE (qvalue)

The downloaded source packages are in
    ‘/tmp/Rtmp4IkQXN/downloaded_packages’
Old packages: 'reshape2', 'RSQLite'
Update all/some/none? [a/s/n]: a
警告: dependency ‘plyr’ is not available
试开URL’http://cran.fhcrc.org/src/contrib/reshape2_1.4.1.tar.gz'
Content type 'application/x-gzip' length 34693 bytes (33 Kb)
打开了URL
==================================================
downloaded 33 Kb

试开URL’http://cran.fhcrc.org/src/contrib/RSQLite_1.0.0.tar.gz'
Content type 'application/x-gzip' length 1745731 bytes (1.7 Mb)
打开了URL
==================================================
downloaded 1.7 Mb

* installing *source* package ‘reshape2’ ...
** 成功将‘reshape2’程序包解包并MD5和检查
** libs
g++ -I/usr/share/R/include -DNDEBUG   -I"/home/li/R/x86_64-pc-linux-gnu-library/2.15/Rcpp/include"   -fpic  -O2 -pipe -g  -c RcppExports.cpp -o RcppExports.o
RcppExports.cpp:9:107: 错误: ‘String’未声明
RcppExports.cpp:9:129: 错误: ‘String’未声明
RcppExports.cpp: 在函数‘SEXPREC* reshape2_melt_dataframe(SEXP, SEXP, SEXP, SEXP, SEXP, SEXP, SEXP, SEXP)’中:
RcppExports.cpp:15:9: 错误: ‘input_parameter’不是‘Rcpp::traits’的成员
RcppExports.cpp:15:40: 错误: expected primary-expression before ‘const’
RcppExports.cpp:15:40: 错误: expected ‘;’ before ‘const’
RcppExports.cpp:16:9: 错误: ‘input_parameter’不是‘Rcpp::traits’的成员
RcppExports.cpp:16:40: 错误: expected primary-expression before ‘const’
RcppExports.cpp:16:40: 错误: expected ‘;’ before ‘const’
RcppExports.cpp:17:9: 错误: ‘input_parameter’不是‘Rcpp::traits’的成员
RcppExports.cpp:17:40: 错误: expected primary-expression before ‘const’
RcppExports.cpp:17:40: 错误: expected ‘;’ before ‘const’
RcppExports.cpp:18:9: 错误: ‘input_parameter’不是‘Rcpp::traits’的成员
RcppExports.cpp:18:40: 错误: ‘String’在此作用域中尚未声明
RcppExports.cpp:18:48: 错误: ‘::type’未被声明
RcppExports.cpp:18:55: 错误: expected ‘;’ before ‘variable_name’
RcppExports.cpp:19:9: 错误: ‘input_parameter’不是‘Rcpp::traits’的成员
RcppExports.cpp:19:48: 错误: ‘::type’未被声明
RcppExports.cpp:19:55: 错误: expected ‘;’ before ‘value_name’
RcppExports.cpp:20:9: 错误: ‘input_parameter’不是‘Rcpp::traits’的成员
RcppExports.cpp:20:45: 错误: expected primary-expression before ‘>’ token
RcppExports.cpp:20:46: 错误: ‘::type’未被声明
RcppExports.cpp:20:53: 错误: expected ‘;’ before ‘measure_attributes’
RcppExports.cpp:21:9: 错误: ‘input_parameter’不是‘Rcpp::traits’的成员
RcppExports.cpp:21:40: 错误: expected primary-expression before ‘bool’
RcppExports.cpp:21:40: 错误: expected ‘;’ before ‘bool’
RcppExports.cpp:22:9: 错误: ‘input_parameter’不是‘Rcpp::traits’的成员
RcppExports.cpp:22:40: 错误: expected primary-expression before ‘bool’
RcppExports.cpp:22:40: 错误: expected ‘;’ before ‘bool’
RcppExports.cpp:23:40: 错误: ‘data’在此作用域中尚未声明
RcppExports.cpp:23:46: 错误: ‘id_ind’在此作用域中尚未声明
RcppExports.cpp:23:54: 错误: ‘measure_ind’在此作用域中尚未声明
RcppExports.cpp:23:67: 错误: ‘variable_name’在此作用域中尚未声明
RcppExports.cpp:23:82: 错误: ‘value_name’在此作用域中尚未声明
RcppExports.cpp:23:94: 错误: ‘measure_attributes’在此作用域中尚未声明
RcppExports.cpp:23:114: 错误: ‘factorsAsStrings’在此作用域中尚未声明
RcppExports.cpp:23:132: 错误: ‘valueAsFactor’在此作用域中尚未声明
make: *** [RcppExports.o] 错误 1
ERROR: compilation failed for package ‘reshape2’
* removing ‘/home/li/R/x86_64-pc-linux-gnu-library/2.15/reshape2’
* restoring previous ‘/home/li/R/x86_64-pc-linux-gnu-library/2.15/reshape2’
* installing *source* package ‘RSQLite’ ...
** 成功将‘RSQLite’程序包解包并MD5和检查
checking for gcc... gcc -std=gnu99
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc -std=gnu99 accepts -g... yes
checking for gcc -std=gnu99 option to accept ISO C89... none needed
checking how to run the C preprocessor... gcc -std=gnu99 -E
checking for gcc... (cached) gcc -std=gnu99
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc -std=gnu99 accepts -g... (cached) yes
checking for gcc -std=gnu99 option to accept ISO C89... (cached) none needed
checking for library containing fdatasync... none required
configure: creating ./config.status
config.status: creating src/Makevars
** libs
gcc -std=gnu99 -I/usr/share/R/include -DNDEBUG -DRSQLITE_USE_BUNDLED_SQLITE -DSQLITE_ENABLE_RTREE -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_SOUNDEX -DSQLITE_MAX_VARIABLE_NUMBER=40000 -DSQLITE_MAX_COLUMN=30000 -DTHREADSAFE=0     -fpic  -O2 -pipe -g  -c connection.c -o connection.o
gcc -std=gnu99 -I/usr/share/R/include -DNDEBUG -DRSQLITE_USE_BUNDLED_SQLITE -DSQLITE_ENABLE_RTREE -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_SOUNDEX -DSQLITE_MAX_VARIABLE_NUMBER=40000 -DSQLITE_MAX_COLUMN=30000 -DTHREADSAFE=0     -fpic  -O2 -pipe -g  -c driver.c -o driver.o
gcc -std=gnu99 -I/usr/share/R/include -DNDEBUG -DRSQLITE_USE_BUNDLED_SQLITE -DSQLITE_ENABLE_RTREE -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_SOUNDEX -DSQLITE_MAX_VARIABLE_NUMBER=40000 -DSQLITE_MAX_COLUMN=30000 -DTHREADSAFE=0     -fpic  -O2 -pipe -g  -c exceptions.c -o exceptions.o
gcc -std=gnu99 -I/usr/share/R/include -DNDEBUG -DRSQLITE_USE_BUNDLED_SQLITE -DSQLITE_ENABLE_RTREE -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_SOUNDEX -DSQLITE_MAX_VARIABLE_NUMBER=40000 -DSQLITE_MAX_COLUMN=30000 -DTHREADSAFE=0     -fpic  -O2 -pipe -g  -c extension-functions.c -o extension-functions.o
gcc -std=gnu99 -I/usr/share/R/include -DNDEBUG -DRSQLITE_USE_BUNDLED_SQLITE -DSQLITE_ENABLE_RTREE -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_SOUNDEX -DSQLITE_MAX_VARIABLE_NUMBER=40000 -DSQLITE_MAX_COLUMN=30000 -DTHREADSAFE=0     -fpic  -O2 -pipe -g  -c fetch.c -o fetch.o
gcc -std=gnu99 -I/usr/share/R/include -DNDEBUG -DRSQLITE_USE_BUNDLED_SQLITE -DSQLITE_ENABLE_RTREE -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_SOUNDEX -DSQLITE_MAX_VARIABLE_NUMBER=40000 -DSQLITE_MAX_COLUMN=30000 -DTHREADSAFE=0     -fpic  -O2 -pipe -g  -c fields.c -o fields.o
gcc -std=gnu99 -I/usr/share/R/include -DNDEBUG -DRSQLITE_USE_BUNDLED_SQLITE -DSQLITE_ENABLE_RTREE -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_SOUNDEX -DSQLITE_MAX_VARIABLE_NUMBER=40000 -DSQLITE_MAX_COLUMN=30000 -DTHREADSAFE=0     -fpic  -O2 -pipe -g  -c importFile.c -o importFile.o
gcc -std=gnu99 -I/usr/share/R/include -DNDEBUG -DRSQLITE_USE_BUNDLED_SQLITE -DSQLITE_ENABLE_RTREE -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_SOUNDEX -DSQLITE_MAX_VARIABLE_NUMBER=40000 -DSQLITE_MAX_COLUMN=30000 -DTHREADSAFE=0     -fpic  -O2 -pipe -g  -c param_binding.c -o param_binding.o
gcc -std=gnu99 -I/usr/share/R/include -DNDEBUG -DRSQLITE_USE_BUNDLED_SQLITE -DSQLITE_ENABLE_RTREE -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_SOUNDEX -DSQLITE_MAX_VARIABLE_NUMBER=40000 -DSQLITE_MAX_COLUMN=30000 -DTHREADSAFE=0     -fpic  -O2 -pipe -g  -c quick_column.c -o quick_column.o
gcc -std=gnu99 -I/usr/share/R/include -DNDEBUG -DRSQLITE_USE_BUNDLED_SQLITE -DSQLITE_ENABLE_RTREE -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_SOUNDEX -DSQLITE_MAX_VARIABLE_NUMBER=40000 -DSQLITE_MAX_COLUMN=30000 -DTHREADSAFE=0     -fpic  -O2 -pipe -g  -c result.c -o result.o
gcc -std=gnu99 -I/usr/share/R/include -DNDEBUG -DRSQLITE_USE_BUNDLED_SQLITE -DSQLITE_ENABLE_RTREE -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_SOUNDEX -DSQLITE_MAX_VARIABLE_NUMBER=40000 -DSQLITE_MAX_COLUMN=30000 -DTHREADSAFE=0     -fpic  -O2 -pipe -g  -c sqlite-all.c -o sqlite-all.o
gcc -std=gnu99 -I/usr/share/R/include -DNDEBUG -DRSQLITE_USE_BUNDLED_SQLITE -DSQLITE_ENABLE_RTREE -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_SOUNDEX -DSQLITE_MAX_VARIABLE_NUMBER=40000 -DSQLITE_MAX_COLUMN=30000 -DTHREADSAFE=0     -fpic  -O2 -pipe -g  -c utils.c -o utils.o
mkdir -p ../inst/include
cp sqlite/sqlite3.h ../inst/include
cp sqlite/sqlite3ext.h ../inst/include
gcc -std=gnu99 -shared -o RSQLite.so connection.o driver.o exceptions.o extension-functions.o fetch.o fields.o importFile.o param_binding.o quick_column.o result.o sqlite-all.o utils.o -L/usr/lib/R/lib -lR
安装至 /home/li/R/x86_64-pc-linux-gnu-library/2.15/RSQLite/libs
** R
** inst
** preparing package for lazy loading
Error in setClass("SQLiteConnection", contains = "DBIConnection", slots = list(Id = "externalptr",  :
  参数((slots = list(Id = "externalptr", dbname = "character", loadable.extensions = "logical", flags = "integer", vfs = "character"))) 没有用
Error : unable to load R code in package ‘RSQLite’
ERROR: lazy loading failed for package ‘RSQLite’
* removing ‘/home/li/R/x86_64-pc-linux-gnu-library/2.15/RSQLite’
* restoring previous ‘/home/li/R/x86_64-pc-linux-gnu-library/2.15/RSQLite’

The downloaded source packages are in
    ‘/tmp/Rtmp4IkQXN/downloaded_packages’
警告信息:
1: installed directory not writable, cannot update packages 'abind', 'car',
  'chron', 'colorspace', 'effects', 'Hmisc', 'lmtest', 'multcomp', 'mvtnorm',
  'relimp', 'rgl', 'sandwich', 'sm', 'strucchange', 'XML', 'zoo', 'cluster',
  'codetools', 'KernSmooth', 'lattice', 'mgcv', 'nnet', 'rpart', 'survival'
2: In install.packages(update[instlib == l, "Package"], l, contriburl = contriburl,  :
  installation of package ‘reshape2’ had non-zero exit status
3: In install.packages(update[instlib == l, "Package"], l, contriburl = contriburl,  :
  installation of package ‘RSQLite’ had non-zero exit status

 

 

Thanks in advance for great help!
 

Yue

plyr qvalue • 2.0k views
ADD COMMENTlink modified 4.4 years ago • written 4.4 years ago by yueli790

Thanks, you are right!

ADD REPLYlink written 4.4 years ago by yueli790
1
gravatar for rtliu
4.4 years ago by
rtliu2.0k
New Zealand
rtliu2.0k wrote:

It seems your R version is too old for plyr,  please upgrade your R version >= 3.1.0

plyr depends: R (≥ 3.1.0)

 

ADD COMMENTlink written 4.4 years ago by rtliu2.0k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 800 users visited in the last hour