Question: (ERR): bowtie2-align exited with value 1
0
gravatar for biostarsb
3.0 years ago by
biostarsb20
biostarsb20 wrote:

Hello

I have a problem with bowtie2 tools

When I type the command bowtie2 -h It shows me the help but with an error message at the end

(ERR): bowtie2-align exited with value 1

Can someone help me solve the problem?

thank you in advance

rna-seq software error • 4.3k views
ADD COMMENTlink modified 2.1 years ago by basucsmcri0 • written 3.0 years ago by biostarsb20

How did you acquire bowtie2? Did you install it yourself or are you using it on a server?

ADD REPLYlink written 3.0 years ago by genomax78k

i installed it myself

ADD REPLYlink written 3.0 years ago by biostarsb20

I am having same problem? did you find out the reason and how to resolve the issue?

ADD REPLYlink written 3.0 years ago by amoltej90

Which version of bowtie2 are you using? I was using bowtie2-2.1.0 and then I noticed that there was a new version (bowtie2-2.3.0), so I've updated it and bowtie2 started giving me this very same error when trying to align sequences to the reference. I went back to bowtie2-2.1.0 and it's working again. I understand that this is not the best solution, but it's still better than no solution at all.

ADD REPLYlink written 3.0 years ago by valengo0

I Have the same error since 2 weeks ago but until now I could not find a way to resolve the error "Bowtie2 (ERR): bowtie2-align exited with value 1" when using tophat2. Please help

ADD REPLYlink written 2.9 years ago by KHP0

I'm having the same problem. I installed the legacy version bowtie2-2.3.2-legacy. It worked fine before, but not now...

ADD REPLYlink written 2.5 years ago by mikoliu7980

I'm having the same problem,and I installed the bowtie2-2.3.4.3 by conda. Did you find out the reason and how to resolve the issue?

ADD REPLYlink written 9 months ago by xk9950

Did you download or make your own bowtie2 indexes?

ADD REPLYlink written 9 months ago by genomax78k

I installed the bowtie2-2.3.4.3 by conda using "conda install -c bioconda bowtie2". When I type the command bowtie2, an error message is at the end "(ERR): bowtie2-align exited with value 1". but I type the ommand bowtie2 -h, it's ok.

ADD REPLYlink written 9 months ago by xk9950

You should enter the complete bowtie2command you want to execute. Since bowtie2 -h is working the programs is properly installed.

ADD REPLYlink written 9 months ago by genomax78k

I am having the same problem- Ubuntu 14.04 virtual box, mac

manager@bl8vbox[Bowtie] which bowtie2                                 [ 8:41PM]
/usr/bin/bowtie2
manager@bl8vbox[Bowtie] which bowtie2-align                           [ 8:46PM]
bowtie2-align not found
manager@bl8vbox[Bowtie]

Can anyone help, it will be much appreciated

ADD REPLYlink modified 2.1 years ago by genomax78k • written 2.1 years ago by basucsmcri0
1

This seems to be a simple issue of bowtie2-align not being in the $PATH. Should be easily fixable by doing export PATH=$PATH:/path_to_bowtie2_executables.

BTW: Why are you using a VM if you are working on a Mac? macOS is a real unix OS and you can compile/run most bioinformatics programs natively. Bowtie2 macOS binaries available here.

ADD REPLYlink modified 2.1 years ago • written 2.1 years ago by genomax78k
1

Or use Homebrew to install Bowtie2.

ADD REPLYlink written 2.1 years ago by e.rempel790
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1442 users visited in the last hour