Question: deeptools installation on MacBook
0
gravatar for BioDH
2.2 years ago by
BioDH0
BioDH0 wrote:

I'm trying install deeptools on my Mac.

I did.

~ pip install --user deeptools

Requirement already satisfied: deeptools in ./Library/Python/2.7/lib/python/site-packages
Requirement already satisfied: numpy>=1.9.0 in ./Library/Python/2.7/lib/python/site-packages (from deeptools)
Requirement already satisfied: scipy>=0.17.0 in ./Library/Python/2.7/lib/python/site-packages (from deeptools)
Requirement already satisfied: matplotlib>=1.4.0 in ./Library/Python/2.7/lib/python/site-packages (from deeptools)
Requirement already satisfied: pysam>=0.8.2 in ./Library/Python/2.7/lib/python/site-packages (from deeptools)
Requirement already satisfied: numpydoc>=0.5 in ./Library/Python/2.7/lib/python/site-packages (from deeptools)
Requirement already satisfied: pyBigWig>=0.2.1 in ./Library/Python/2.7/lib/python/site-packages (from deeptools)
Requirement already satisfied: py2bit>=0.2.0 in ./Library/Python/2.7/lib/python/site-packages (from deeptools)
Requirement already satisfied: pyparsing!=2.0.0,!=2.0.4,!=2.1.2,!=2.1.6,>=1.5.6 in /System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python (from matplotlib>=1.4.0->deeptools)
Requirement already satisfied: functools32 in ./Library/Python/2.7/lib/python/site-packages (from matplotlib>=1.4.0->deeptools)
Requirement already satisfied: pytz in /System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python (from matplotlib>=1.4.0->deeptools)
Requirement already satisfied: six>=1.10 in ./Library/Python/2.7/lib/python/site-packages (from matplotlib>=1.4.0->deeptools)
Requirement already satisfied: cycler>=0.10 in ./Library/Python/2.7/lib/python/site-packages (from matplotlib>=1.4.0->deeptools)
Requirement already satisfied: subprocess32 in ./Library/Python/2.7/lib/python/site-packages (from matplotlib>=1.4.0->deeptools)
Requirement already satisfied: python-dateutil in /System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python (from matplotlib>=1.4.0->deeptools)
~

But If type "bamCoverage"

~ bamCoverage

-bash: bamCoverage: command not found

~ deeptools

-bash: deeptools: command not found

How can I use deeptools.

What's wrong with deeptools

install deeptools mac • 1.2k views
ADD COMMENTlink modified 24 months ago by inowkeren0 • written 2.2 years ago by BioDH0
0
gravatar for genomax
2.2 years ago by
genomax67k
United States
genomax67k wrote:

Depending where deepTools was installed you may need to add that directory to your $PATH in order to be directly able to run the program: http://unix.stackexchange.com/questions/183295/adding-programs-to-path

That location may be $HOME/.local/bin/ (since you did not specify a location during install). If $HOME/.local/bin/bamCoverage --help produces a help output add $HOME/.local/bin/ directory to your $PATH.

ADD COMMENTlink modified 2.2 years ago by Devon Ryan90k • written 2.2 years ago by genomax67k
0
gravatar for inowkeren
24 months ago by
inowkeren0
inowkeren0 wrote:

assuming there is a deepTools folder in your home folder, in the terminal: export path=~/deepTools/bin:$path

thanks

ADD COMMENTlink written 24 months ago by inowkeren0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 728 users visited in the last hour