Question: How can I install an older version of affy in order to install CellNet?
0
gravatar for tannaz
2.0 years ago by
tannaz0
tannaz0 wrote:

I have this problem with installing CellNet. I keep having this eror:


Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) : namespace ‘affy’ 1.54.0 is being loaded, but <= 1.36.1 is required ERROR: lazy loading failed for package ‘cellnetr’


so I tried to install affy 1.36.1 yet there is another error like below:


Error : object ‘@<-’ is not exported by 'namespace:methods' ERROR: lazy loading failed for package ‘affy’


what can I do?

p.s I have R 3.4.0 installed.

R software error • 840 views
ADD COMMENTlink modified 2.0 years ago by Santosh Anand4.9k • written 2.0 years ago by tannaz0
1
gravatar for Santosh Anand
2.0 years ago by
Santosh Anand4.9k
Santosh Anand4.9k wrote:

Install a new version of R locally, with the right version of BioConductor ( https://www.bioconductor.org/help/search/index.html?q=affy/ ), which has got the right version affy

ADD COMMENTlink modified 2.0 years ago • written 2.0 years ago by Santosh Anand4.9k

I installed BioConductor 2.11 (hopefully the right one!) with this command:

install.packages("BiocInstaller", repos="http://bioconductor.org/packages/2.11/bioc")

after that I install affy but it was 1.38.1 instead of 1.36.1!!

ADD REPLYlink written 2.0 years ago by tannaz0
1

Hmmmm... Either move to lower version of BioC or install from source, after dloading the affy source from https://www.bioconductor.org/packages/2.11/bioc/src/contrib/affy_1.36.1.tar.gz

install.packages(path_to_file, repos = NULL, type="source")

ADD REPLYlink written 2.0 years ago by Santosh Anand4.9k

I've already tried this. I got this error:

installing to /home/tannaz/R/x86_64-pc-linux-gnu-library/3.4/affy/libs * R * data * demo * inst ** preparing package for lazy loading Error : object ‘@<-’ is not exported by 'namespace:methods' ERROR: lazy loading failed for package ‘affy’ * removing ‘/home/tannaz/R/x86_64-pc-linux-gnu-library/3.4/affy’ Warning in install.packages : installation of package ‘/home/tannaz/R/x86_64-pc-linux-gnu-library/3.4/affy_1.36.1.tar.gz’ had non-zero exit status

ADD REPLYlink written 2.0 years ago by tannaz0
1

Could you also check your version of BioC.

source("http://bioconductor.org/biocLite.R")
biocLite()

affy 1.38.1 is default for BioC 2.12!

ADD REPLYlink written 2.0 years ago by Santosh Anand4.9k
1

Your BioC install method is not correct. First you need to install the corresponding version of R, then use

source("http://bioconductor.org/biocLite.R")
biocLite()

This will get the right version of BioC.

You may also try installing right version of affy by src https://www.bioconductor.org/packages/2.11/bioc/src/contrib/affy_1.36.1.tar.gz

install.packages(path_to_file, repos = NULL, type="source")

However, I am afraid that there is something changed in the Base R, that is why you are getting this error [ object ‘@<-’ is not exported by 'namespace:methods' ]. So your last and only solution might be the re installation of a lower version of R locally

https://unix.stackexchange.com/questions/149451/install-r-in-my-own-directory

ADD REPLYlink written 2.0 years ago by Santosh Anand4.9k

Aha got it. Thanks a lot.

ADD REPLYlink written 2.0 years ago by tannaz0

yeah! you're right! it seems BioC 2.12 is installed! but this is the command that I used and as you see I typed "2.11" !!

install.packages("BiocInstaller", repos="http://bioconductor.org/packages/2.11/bioc")

ADD REPLYlink written 2.0 years ago by tannaz0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1575 users visited in the last hour