samtools installation errors
2
0
Entering edit mode
6.4 years ago
saj98 ▴ 140

Hello everyone I am trying to install samtools version 1.6 I downloaded it from the following resource [https://sourceforge.net/projects/samtools/files/samtools/1.6/]. Then I run the following command ./configure , so it came fine with no error. Then I run make, it came fine with no error. When I run make install . It gave the following error shaima@sarkarlab-MS-7885-Invalid-entry-length-16-Fixed-up-to-11:~/Downloads/samtools-1.6$ make install, the error is mkdir -p -m 755 /usr/local/bin /usr/local/bin /usr/local/share/man/man1 install -p samtools /usr/local/bin install: cannot create regular file '/usr/local/bin/samtools': Permission denied Makefile:292: recipe for target 'install' failed make: *** [install] Error 1

I appreciate your help and time

software error • 7.0k views
ADD COMMENT
1
Entering edit mode
6.4 years ago
fishka ▴ 30

try

make clean


make


sudo make install
ADD COMMENT
0
Entering edit mode

Thank you I got it

ADD REPLY
0
Entering edit mode
6.4 years ago
fishka ▴ 30

you have to add sudo

sudo make install

ADD COMMENT
0
Entering edit mode

I did it, but now gave me the following error cd htslib-1.6 && make htslib_static.mk make[1]: Entering directory '/home/shaima/Downloads/samtools-1.6/htslib-1.6' sed -n '/^static_libs=/s/[^=]*=/HTSLIB_static_LIBS = /p;/^static_ldflags=/s/[^=]*=/HTSLIB_static_LDFLAGS = /p' htslib.pc.tmp > htslib_static.mk make[1]: Leaving directory '/home/shaima/Downloads/samtools-1.6/htslib-1.6' make: Nothing to be done for 'all'.

ADD REPLY
0
Entering edit mode

If you have administrator privileges (and therefore can use sudo) you can also try to install samtools from your package manager. For instance on Debian and Ubuntu: sudo apt install samtools. It may not be the latest version, though backports often get eventually provided.

ADD REPLY

Login before adding your answer.

Traffic: 1353 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6