Question: [OP Inactive] clusterProfiler (enrichKEGG) error
0
gravatar for bikash2510
13 months ago by
bikash251030
bikash251030 wrote:

Getting error still after using correct entrezid for BPM4 gene.

> x="652"
> kk <- enrichKEGG(gene         = x,
+                  organism     = 'hsa',
+                  pvalueCutoff = 0.05)

--> No gene can be mapped....

--> Expected input gene ID: 2194,2271,126,54898,574537,124

--> return NULL...

ADD COMMENTlink modified 13 months ago by RamRS21k • written 13 months ago by bikash251030
1

There might be several reasons:

1) The entrezid is not the correct one. You might try to feed clusterprofiler all the sysnonyms you find on NCBI and see if one works (I remember having hard times understanding the correct format).

2) Maybe the gene is simply not mapped in KEGG. You can search for it in the KEGG database directly and see if you find it.

ADD REPLYlink modified 13 months ago • written 13 months ago by Fabio Marroni2.2k
1

Hello bikash2510,

Please format your post better so it's easier to read. Also, use more verbose description for the problem and not bullet points that make the question look more like personal notes - the more context you give people, the better help they can give you.

ADD REPLYlink written 13 months ago by RamRS21k

Some entrezid can't be mapped by clusterprofiller e.g- 4057(LTF),4856(NOV),56603(CYP26B1),6424(SFRP4), I am unable to get what wrong with clusterprofiller.

ADD REPLYlink modified 13 months ago • written 13 months ago by bikash251030

This is what I see common to these entries: multiple comma-separated values under gene name. Could that be a factor?

ADD REPLYlink written 13 months ago by RamRS21k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1441 users visited in the last hour