Question: Jellyfish version problem Kraken
0
gravatar for owenz
3 months ago by
owenz10
owenz10 wrote:

I installed Kraken on Linux and was about to build the bacterial db. Unfortunately, the Jellyfish version installed was 2.2.8 which is not compatible with Kraken.

I uninstalled this version and tried to install the necessary 1.1.11 version through apt. Unfortunately it was not retrieved.

I download the tar.gz and tried to change the PATH variable but when I tried to enter the Kraken build command, it was still not effecting.

Could this also be a problem with Kraken and the threads required? What should be the ideal thread count?

Thanks in advance

jellyfish kraken • 166 views
ADD COMMENTlink modified 3 months ago • written 3 months ago by owenz10

The problem now seems to be to limit hash size on a 32gb Ram PC. What should be ideal?

ADD REPLYlink written 3 months ago by owenz10

Find other hardware with more RAM? There is really no substitute for lack of adequate RAM.

ADD REPLYlink written 3 months ago by genomax62k

Both Kraken and Kraken2 provide a "MiniKraken" pre-built database, including bacterial, archaeal, and viral genomes:

https://www.ccb.jhu.edu/software/kraken/dl/minikraken_20171019_8GB.tgz

https://www.ccb.jhu.edu/software/kraken2/dl/minikraken2_v1_8GB.tgz

ADD REPLYlink written 3 months ago by h.mon23k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1606 users visited in the last hour