oma -c error report
0
0
Entering edit mode
9 months ago
Sadie4444 • 0

Hi,

I tried to run oma -c option. However, I got error report like this

Cannot load GETHOG bottom-up library properly:
Error: Command '['/BIGDATA1/sysu_lygu_1/lg/OMA/OMA.2.4.1/.venv/bin/python3', '-Im', 'ensurepip', '--upgrade', '--default-pip']' returned non-zero exit status 2.
/usr/bin/python: No module named virtualenv
Neither python2 nor python3 seem to be available on this system.
cannot find GETHOGs Bottom-Up

Error, (in _check_HOG_params) Cannot load GETHOG bottom-up library properly

However, I have already installed python3 in the cluster. And before it runs very well. I did not change the environment. Could anyone know why this happens? Thanks a lot!

Best, LG

oma • 311 views
ADD COMMENT
0
Entering edit mode

What happened to the problem you were facing earlier? Did you find a solution?

ADD REPLY
0
Entering edit mode

Hi Sadie,

what does it mean that it was running before very well? another version of OMA standalone? or this version on a different machine, or on the login node?

Did you install oma or do you just start it from the extracted tarball? what happens if you try to run python3 -m venv .venv in the console from the same directory where you launch oma? this command seems to fail from the output. If you're running OMA on a HPC cluster, it might be that you need to load your environment again after launching a job.

Cheers Adrian

ADD REPLY

Login before adding your answer.

Traffic: 2349 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6