Question: Error When Installing Emboss
2
gravatar for biolab
4.0 years ago by
biolab970
biolab970 wrote:

Dear All,

I am installing EMBOSS on my UBUNTU system. I follow ./configure, make and make install. At make install step, there is an error appearing as follows: error while loading shared libraries: libnucleus.so.6: cannot open shared object file: No such file or directory

I am asking Biostar members how to resolve this problem. THANKS very much!!

software • 4.9k views
ADD COMMENTlink modified 3.7 years ago by Paul130 • written 4.0 years ago by biolab970
13
gravatar for Paul
3.7 years ago by
Paul130
Paul130 wrote:

I had this same problem today, and the available responses to the question did not help. I finally figured it out after some struggle. I though I should share the solution, in case someone else stumbles across this page. The EMBOSS installer does not refresh the library load cache, and therefore the installed libraries are not visible. The fix is to execute the following command as root after make install:

ldconfig

At this point one can run make install one more time just to make sure everything is OK.

ADD COMMENTlink modified 3.7 years ago • written 3.7 years ago by Paul130

+1 worked for me

ADD REPLYlink written 3.7 years ago by Medhat7.1k

Thanks Paul, your fix is the only one that worked for me as well...(for the install from source of course)

ADD REPLYlink modified 3.2 years ago • written 3.2 years ago by atisou0

Thanks Paul. It works.

ADD REPLYlink written 2.2 years ago by shzhang0
4
gravatar for Neilfws
4.0 years ago by
Neilfws47k
Sydney, Australia
Neilfws47k wrote:

If you don't need the latest and greatest, it's as simple as:

sudo apt-get install emboss

Otherwise, libnucleus.so.6 is found in the emboss-lib package so:

sudo apt-get install emboss-lib

That should install to /usr/lib/emboss/lib/.

ADD COMMENTlink written 4.0 years ago by Neilfws47k
1

Installing a package managed library and then installing a built from source version is not a good idea. As well as version mismatch issues this can cause problems with package dependencies. It is best to either use the packages or build from source, when installing to system locations (e.g. /usr/ or /usr/local/).

That said if you need to have both the package managed version (say to handle package dependencies, or provide specific features) and a source build (to provide a specific version, to test a new version, to have the latest version or to support development), you can do this as long as you install the source based build to a local installation location using the '--prefix=location' option to configure. For example I typically install source based EMBOSS builds into '$HOME/usr/EMBOSS-version', so I can have multiple versions available (handy when working out if a specific behaviour is a bug), while still using the Debian med EMBOSS packages by default.

ADD REPLYlink modified 4.0 years ago • written 4.0 years ago by Hamish3.0k

Yes, I retract the second part of that answer - mix and match not a good idea.

I think you just need to clean up and start again as Hamish suggests. I have never had a problem with EMBOSS install on any Ubuntu machine. It sounds like you are dealing with "your own local mess", which is always difficult for others to troubleshoot :)

ADD REPLYlink written 4.0 years ago by Neilfws47k

i run sudo apt-get install emboss-lib, and then make install, finally make installcheck. There are two minor errors: runJemboss.sh does not support *[installchekc-binSCRIPTS] error1 Leaving directory 'xxx/jemboss' * [installcheck-recursive] error1 leaving directory 'xxx/jemboss' . So it seems i cannot run jemboss package, do you think it a minor error? THANKS!!

ADD REPLYlink written 4.0 years ago by biolab970
3
gravatar for Hamish
4.0 years ago by
Hamish3.0k
UK
Hamish3.0k wrote:

That error suggests that 'libnucleus' failed to build correctly. This implies that you are either missing a build dependency (and 'configure' has not omitted it correctly), or your configuration flags are not appropriate.

So your first step is to clean-up your build:

make distclean

Now configure the build again:

./configure

Using any desired flags, for example:

  • Specify the installation location: --prefix=$HOME/usr/EMBOSS-6.6.0
  • Disable MySQL support: --without-mysql
  • Disable Postgres support: --without-postgresql
  • Disable support for SOAP web services (requires Axis2/C): --without-axis2c
  • Disable PDF graphics output: --without-hpdf
  • Disable X11 graphics: --without-x

See the output of './configure --help' for a wide range of other options.

When running 'configure' check the output for expected features being included. For example:

X11 support:

checking X11/Xlib.h usability... yes
checking X11/Xlib.h presence... yes
checking for X11/Xlib.h... yes

PDF support:

checking whether to look for pdf support... yes
checking for HPDF_New in -lhpdf... yes
PDF support found

PNG support:

checking if png driver is wanted... yes
checking for inflateEnd in -lz... yes
checking for png_destroy_read_struct in -lpng... yes
checking for gdImageCreateFromPng in -lgd... yes
PNG libraries found

If these fail it suggests your are missing the associated development packages for the required libraries, so the compiler tests cannot build the sample programs and the feature cannot be used.

Once you have 'configure' producing the desired build configuration, then compile:

make

This will take a little while. If it fails with an error try to run the compile again:

make

And see if the error tells you anything (missing dependency maybe). If the failure is persistent, report it to the EMBOSS developers .

While the basic EMBOSS tests are not that great, it is worth running them to see if you have any serious issues:

make check

Again if this fails try again, if it still fails report to the EMBOSS folks.

Finally if all is well, install to the location specified by '--prefix', or the default '/usr/local/':

make install

Support for EMBOSS is available from the EMBOSS community via the EMBOSS mailing lists, see http://emboss.open-bio.org/html/use/ch03s04.html

ADD COMMENTlink modified 4.0 years ago • written 4.0 years ago by Hamish3.0k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 690 users visited in the last hour