problems updating biomaRt in R version 3.0
1
0
Entering edit mode
8.2 years ago
Max ▴ 140

I recently upgraded R on our servers to version 3.0, and when I attempted to to access biomaRt with library("biomaRt"), I get the error message

Error: package 'biomaRt' was built before R 3.0.0: please re-install it

However, executing the standard command

source("http://bioconductor.org/biocLite.R")
biocLite("biomaRt")

fails to reinstall/update biomaRt, as I get the same error the next time I attempt to access the biomaRt library. What do I need to do in order to reinstall biomaRt for compatibility with R 3.0.0?

BiomaRt bioconductor • 4.3k views
ADD COMMENT
0
Entering edit mode
8.2 years ago
Neilfws 49k
  1. Check that there is not another biomaRt build somewhere on your system (e.g. in a system-wide location)
  2. If you've upgraded R version, you probably need to upgrade Bioconductor too:

    biocLite("BiocUpgrade")
    
ADD COMMENT
0
Entering edit mode

It seems as though there's a whole host of dependencies that need to be upgraded, e.g.

Error : package 'RCurl' was built before R 3.0.0: please re-install it
ERROR: lazy loading failed for package 'biomaRt'
* removing '/usr/local/lib/R/site-library/biomaRt'
* restoring previous '/usr/local/lib/R/site-library/biomaRt'
ADD REPLY
0
Entering edit mode

In that case try:

update.packages(check.built = TRUE, ask = FALSE)

but be aware, it is difficult to provide advice since we cannot know the precise history and state of your system.

ADD REPLY

Login before adding your answer.

Traffic: 1718 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6