Question: Breakdancer installing problem
1
gravatar for salvocamiolo
5.1 years ago by
salvocamiolo20
Italy
salvocamiolo20 wrote:

 

 

Hi guys

I am trying to install breakdancer on my opensuse distro. When I run "make" I receive the following error:

 

[code]

[ 14%] Built target boost-libs
[ 15%] Performing build step for 'samtools-lib'
make[2]: *** [vendor/src/samtools-lib-stamp/samtools-lib-build] Errore 2
make[1]: *** [CMakeFiles/samtools-lib.dir/all] Errore 2
make: *** [all] Errore 2
salvo@linux-t9bq:~/breakdancer/build> su -x "make clean"
su: opzione non valida -- "x"
Try 'su --help' for more information.
salvo@linux-t9bq:~/breakdancer/build> su -c "make clean"
Password:
salvo@linux-t9bq:~/breakdancer/build> su -c "make"
Password:
[  1%] Creating directories for 'boost-libs'
[  3%] Performing download step (verify and extract) for 'boost-libs'
-- verifying file...
     file='/home/salvo/breakdancer/vendor/boost-1.54-breakdancer.tar.gz'
-- verifying file... warning: did not verify file - no URL_MD5 checksum argument? corrupt file?
-- extracting...
     src='/home/salvo/breakdancer/vendor/boost-1.54-breakdancer.tar.gz'
     dst='/home/salvo/breakdancer/build/vendor/boost/boost-src'
-- extracting... [tar xfz]
-- extracting... [analysis]
-- extracting... [rename]
-- extracting... [clean up]
-- extracting... done
[  5%] No patch step for 'boost-libs'
[  7%] No update step for 'boost-libs'
[  8%] Performing configure step for 'boost-libs'
Building Boost.Build engine with toolset gcc... tools/build/v2/engine/bin.linuxx86_64/b2
Detecting Python version... 2.7
Detecting Python root... /usr
Unicode/ICU support for Boost.Regex?... not found.
Generating Boost.Build configuration in project-config.jam...

Bootstrapping is done. To build, run:

    ./b2

To adjust configuration, edit 'project-config.jam'.
Further information:

   - Command line help:
     ./b2 --help

   - Getting started guide:
     http://www.boost.org/more/getting_started/unix-variants.html

   - Boost.Build documentation:
     http://www.boost.org/boost-build2/doc/html/index.html

[ 10%] Performing build step for 'boost-libs'
[ 12%] No install step for 'boost-libs'
[ 14%] Completed 'boost-libs'
[ 14%] Built target boost-libs
[ 15%] Creating directories for 'samtools-lib'
[ 17%] Performing download step (verify and extract) for 'samtools-lib'
-- verifying file...
     file='/home/salvo/breakdancer/vendor/samtools-0.1.19.tar.gz'
-- verifying file... warning: did not verify file - no URL_MD5 checksum argument? corrupt file?
-- extracting...
     src='/home/salvo/breakdancer/vendor/samtools-0.1.19.tar.gz'
     dst='/home/salvo/breakdancer/build/vendor/samtools'
-- extracting... [tar xfz]
-- extracting... [analysis]
-- extracting... [rename]
-- extracting... [clean up]
-- extracting... done
[ 19%] No patch step for 'samtools-lib'
[ 21%] No update step for 'samtools-lib'
[ 22%] Performing configure step for 'samtools-lib'
Building samtools, build log at /home/salvo/breakdancer/build/vendor/samtools/build.log
[ 24%] Performing build step for 'samtools-lib'
make[2]: *** [vendor/src/samtools-lib-stamp/samtools-lib-build] Errore 2
make[1]: *** [CMakeFiles/samtools-lib.dir/all] Errore 2
make: *** [all] Errore 2

[/code]

Any suggestion?

thanks for the help!

 

 

software error • 3.2k views
ADD COMMENTlink modified 5.1 years ago • written 5.1 years ago by salvocamiolo20

Quick question: Why are you using su for make?

ADD REPLYlink written 5.1 years ago by RamRS24k

that was just a try. Since I got the same error by running just "make" I tried also running "make" with super user .

 

ADD REPLYlink written 5.1 years ago by salvocamiolo20

make usually never requires super user permissions. su make can prove troublesome. Could you maybe try installing samtools-lib first? May I ask what OS+version you're using?

ADD REPLYlink written 5.1 years ago by RamRS24k

thanks for the reply! I am running opensuse 12.2

ADD REPLYlink written 5.1 years ago by salvocamiolo20

I'd suggest installing samtools independently and editing the makefile to point to the installed samtools. Instructions from the manual:

.. open 'Makefile' in the 'cpp' directory, redirect '-I/gsc/pkg/bio/samtools/samtools-0.1.6/' to the place you installed your samtools. Then 'make' again, in which case you generate your own binary, which will overwrite the downloaded one.

ADD REPLYlink modified 5 weeks ago • written 5.1 years ago by RamRS24k

Did you follow the install instructions?

ADD REPLYlink modified 5.1 years ago • written 5.1 years ago by nnutter210

Hi there,

yes I followed those instructions and get the error upon trying the "make" step.

ADD REPLYlink written 5.1 years ago by salvocamiolo20
0
gravatar for salvocamiolo
5.1 years ago by
salvocamiolo20
Italy
salvocamiolo20 wrote:

Ok Guys, I thing I sorted it out. The installing instructions generated the error I reported on opensuse 12.2.

I then downloaded the cpp/perl package from sourceforgenet. In order to compile the cpp part I had to change the path of the samtools package as suggested by RamRS (thanks for that). Moreover compiling failed again. I had to add also the flag -lpthread in the Makefile in order to make it work.

For the perl part the script did not work straight away because of some module missing. I had to install the following modules from CPAN:

Now everything seems to work fine.

Thanks everyone for your useful suggestions!

ADD COMMENTlink modified 5 weeks ago by RamRS24k • written 5.1 years ago by salvocamiolo20
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1405 users visited in the last hour