Question: Unable to install XLconnect package in R studio version 3.2.1
0
gravatar for Debbie
5.3 years ago by
Debbie10
United States
Debbie10 wrote:

 

I am new in R. Trying to install XL connect to read my excel file. However when I am typing

> install.packages("XLconnect") or

 > install.packages("XLConnect", dependencies=TRUE)

I am getting the following error:

Warning in install.packages :
  unable to access index for repository /src/contrib
Installing package into ‘/Users/banerjeed/Library/R/3.2/library’
(as ‘lib’ is unspecified)
Warning in install.packages :
  unable to access index for repository /src/contrib
Warning in install.packages :
  package ‘XLconnect’ is not available (for R version 3.2.1)
Warning in install.packages :
  unable to access index for repository /bin/macosx/mavericks/contrib/3.2

Is it really the version is wrong? I am also tried installing RCurl got the same message. I am using a 64bit Mac, Java 8.

Cannot understand where the problem is .Kindly help.

Thanks. Debbie

 

R • 9.6k views
ADD COMMENTlink modified 16 months ago by sansritisinha0 • written 5.3 years ago by Debbie10

Possible problem:

Watch out for capitalization. Try XLConnect in place of XLconnect.

Diagnostic:

You can type library(XLConnect) to see whether the package is actually installed. Unless your installation worked, it'll say Error in library(XLConnect) : there is no package called 'XLConnect'.

Solutions:

If you still have trouble, you may find this page helpful: http://stackoverflow.com/questions/25721884/how-should-i-deal-with-package-xxx-is-not-available-for-r-version-x-y-z-wa

ADD REPLYlink modified 12 months ago by _r_am31k • written 5.3 years ago by eric.kern13190

Thanks for your response. I tried with both got the same error. Then went to R and installed it. Came back to R studio, then found it available to be installed in R studio. Just tried again then, got successfully installed in R studio too. Didn't understand what the problem was , but it got solved. Thanks for your response though.

ADD REPLYlink written 5.3 years ago by Debbie10

Hi, I am using R 3.5.3 and I am unable to install xlconnect package. I get the following error:

install.packages("XLConnect") Installing package into ‘C:/Users/sansrity_thinkpad/Documents/R/win-library/3.5’ (as ‘lib’ is unspecified) trying URL 'https://cran.rstudio.com/bin/windows/contrib/3.5/XLConnect_0.2-15.zip' Content type 'application/zip' length 9831862 bytes (9.4 MB) downloaded 9.4 MB

package ‘XLConnect’ successfully unpacked and MD5 sums checked

The downloaded binary packages are in C:\Users\sansrity_thinkpad\AppData\Local\Temp\RtmpUVmLER\downloaded_packages

library(XLConnect) Loading required package: XLConnectJars Error: package or namespace load failed for ‘XLConnectJars’: .onLoad failed in loadNamespace() for 'rJava', details: call: fun(libname, pkgname) error: No CurrentVersion entry in Software/JavaSoft registry! Try re-installing Java and make sure R and Java have matching architectures. Error: package ‘XLConnectJars’ could not be loaded

How shall I proceed?

ADD REPLYlink written 16 months ago by sansritisinha0

Please ask this over at StackExchange as this is not bioinformatics-related.

ADD REPLYlink written 16 months ago by ATpoint42k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 2105 users visited in the last hour