Question: Need: Bowtie Executable On Ia64
0
gravatar for Rm
7.2 years ago by
Rm7.8k
Danville, PA
Rm7.8k wrote:

I am unable to compile Bowtie 0.12.7 on IA64 computer: are there any bowtie executables available or I will appreciate if some one is willing to share

Error message aded:

$ make
cat ebwt_build.cpp ccnt_lut.cpp ref_read.cpp alphabet.c shmem.cpp edit.cpp ebwt.cpp aligner_0mm.h aligner_1mm.h aligner_23mm.h aligner.h aligner_metrics.h aligner_seed_mm.h alphabet.h annot.h assert_helpers.h auto_array.h binary_sa_search.h bitpack.h bitset.h blockwise_sa.h color_dec.h color.h diff_sample.h ebwt.h ebwt_search_backtrack.h ebwt_search_util.h edit.h endian_swap.h filebuf.h formats.h hit.h hit_set.h log.h mm.h multikey_qsort.h pat.h pool.h qual.h random_source.h range_cache.h range_chaser.h range.h range_source.h ref_aligner.h reference.h refmap.h ref_read.h row_chaser.h sam.h search_globals.h sequence_io.h shmem.h spinlock.h str_util.h threading.h timer.h tokenize.h word_io.h zbox.h | md5sum | awk '{print $1}' > .bowtie-build.md5
/usr/bin/g++ -O3  -DCOMPILER_OPTIONS="\"-O3   -Wl,--hash-style=both  \""  -Wl,--hash-style=both   \
        -DEBWT_BUILD_HASH=`cat .bowtie-build.md5` \
        -fno-strict-aliasing -DBOWTIE_VERSION="\"`cat VERSION`\"" -DBUILD_HOST="\"`hostname`\"" -DBUILD_TIME="\"`date`\"" -DCOMPILER_VERSION="\"`/usr/bin/g++ -v 2>&1 | tail -1`\"" -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -DBOWTIE_PTHREADS -DPREFETCH_LOCALITY=2 -DBOWTIE_MM -DBOWTIE_SHARED_MEM  -DNDEBUG -Wall \
        -I SeqAn-1.1 \
        -o bowtie-build ebwt_build.cpp \
        ccnt_lut.cpp ref_read.cpp alphabet.c shmem.cpp edit.cpp ebwt.cpp  bowtie_build_main.cpp \

/usr/lib/gcc/ia64-suse-linux/4.1.0/../../../../ia64-suse-linux/bin/ld: unrecognized option '--hash-style=both'
/usr/lib/gcc/ia64-suse-linux/4.1.0/../../../../ia64-suse-linux/bin/ld: use the --help option for usage information
collect2: ld returned 1 exit status
make: *** [bowtie-build] Error 1

$ /usr/bin/ld --version

GNU ld version 2.16.91.0.5 20051219 (SUSE Linux)
bowtie • 2.1k views
ADD COMMENTlink modified 7.2 years ago • written 7.2 years ago by Rm7.8k
2

Can you post the error you are receiving when you try to compile?

ADD REPLYlink written 7.2 years ago by Keith Callenberg890
1

I assume that bowtie doesn't use configure to adapt to different versions of build tools and platform, thus using an unsupported option in this version of ld. I would try it the hard and dirty way, if that option is not supported it serves (maybe;) no purpose, get rid of it, therefor open the Makefile, find '--hash-style=both' remove it and try to compile again. Ofc, testing the built app is advisable.

ADD REPLYlink written 7.2 years ago by Michael Dondrup46k

@Keith: I have added the error message

ADD REPLYlink written 7.2 years ago by Rm7.8k

I assume that bowtie doesn't use configure to adapt to different versions of build tools and platform, thus using an unsupported option in this version of ld. I would try it the hard and dirty way, if that option is not supported it serves (maybe), get rid of it, therefor open the Makefile, find '--hash-style=both' remove it and try to compile again. Ofc, testing the built app is advisable.

ADD REPLYlink written 7.2 years ago by Michael Dondrup46k

@Michael: It worked with your suggestion: can you post it as an answer : I will accept it.

ADD REPLYlink written 7.2 years ago by Rm7.8k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 686 users visited in the last hour