Question: ViennaRNA package installation
1
gravatar for rrsowmya
4.6 years ago by
rrsowmya20
United States
rrsowmya20 wrote:

I'm trying to install ViennaRNA package on my home directory like

,/configure --prefix=/home/username make install

But it returns the following... * no rule to make target 'install'. stop

Can anyone tell me what seems to be the problem?

rna-seq software error • 2.6k views
ADD COMMENTlink written 4.6 years ago by rrsowmya20

Is there any Makefile ?

ADD REPLYlink written 4.6 years ago by venu6.7k

Presumably ./configure threw an error. Look in config.log for details.

ADD REPLYlink written 4.6 years ago by Devon Ryan96k

Thanks. Yes the makefiles are in there. I looked through the configure log file and I get the following warning configure: WARNING: SWIG version >= 2.0.0 is required. You have 1.3.40. Would that be the issue. If so can I resolve the issue at my end? OR do I contact the system admin for it?

ADD REPLYlink written 4.6 years ago by rrsowmya20
1

In general, it helps if you state on which operating system you are trying to install which particular version of a given package.

The Swig on your system is a fairly old version, which in turns indicates you are running a very old OS. The ViennaRNA devs provide several binary packages, you could try asking your SysAdmin to install one of those binaries. Otherwise, you will have to install a newer SWIG and pass its location to the configure script.

ADD REPLYlink written 4.6 years ago by h.mon31k

Thank you. I'm trying to install ViennaRNA-2.2.4 (the latest version) on Unix. I will try using other binaries and if the error persists try contacting the SysAdmin.

ADD REPLYlink written 4.6 years ago by rrsowmya20
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1265 users visited in the last hour