Question: Popoolation variance-sliding.pl output shows only zero value
0
gravatar for divya
14 months ago by
divya20
divya20 wrote:

Hello

I am using Popoolation tool to calculate Tajima's D, Pi, and Watterson's Theta of my pool population by using "Variance-sliding.pl" script from mpileup data file . But the output generated shows 0 value in 3rd and 4th column and in 5th show "na". Eg:

4 125000 0 0.000 na

4 127000 0 0.000 na

4 129000 0 0.000 na

4 131000 0 0.000 na

4 133000 0 0.000 na

I follow the whole steps as per given in manual. So please guide me how to solve this above error, it's urgent.

Thank you,

Divya

ADD COMMENTlink modified 7 months ago by antaky0 • written 14 months ago by divya20

Please anyone guide me how to solve this error.

ADD REPLYlink written 14 months ago by divya20
2
gravatar for lay_0
14 months ago by
lay_050
lay_050 wrote:

Hello diva, I hope this helps, I found this comment in the popoolation wiki website

"Values of 0 and na in my case came from using a bam file generated from reads using phred33 scores when the default of the Variance-sliding.pl script is to use phred64 encoding. Specify "--fastq-type sanger" to use the phred33 scoring scheme."

ADD COMMENTlink written 14 months ago by lay_050
0
gravatar for antaky
7 months ago by
antaky0
antaky0 wrote:

I am getting a very similar error for the d output. It gives number of snps found but no tajima's d value... I tried using both "--fastq-type sanger" and "--fastq-type illumina". Please any help? line example: dDocent_Contig_13 500 0 0.000 na

ADD COMMENTlink modified 7 months ago • written 7 months ago by antaky0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 766 users visited in the last hour